summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/aiounittest/aiounittest-1.4.2.ebuild')
-rw-r--r--dev-python/aiounittest/aiounittest-1.4.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/aiounittest/aiounittest-1.4.2.ebuild b/dev-python/aiounittest/aiounittest-1.4.2.ebuild
new file mode 100644
index 000000000000..0fb0a6c0046b
--- /dev/null
+++ b/dev-python/aiounittest/aiounittest-1.4.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Test asyncio code more easily"
+HOMEPAGE="
+ https://github.com/kwarunek/aiounittest/
+ https://pypi.org/project/aiounittest/
+"
+SRC_URI="
+ https://github.com/kwarunek/aiounittest/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/wrapt[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest