summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ansi')
-rw-r--r--dev-python/ansi/Manifest1
-rw-r--r--dev-python/ansi/ansi-0.1.5.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/ansi/Manifest b/dev-python/ansi/Manifest
index 3df0150bb7e0..d108215ce230 100644
--- a/dev-python/ansi/Manifest
+++ b/dev-python/ansi/Manifest
@@ -1 +1,2 @@
DIST ansi-0.1.3.tar.gz 4561 BLAKE2B 33f1bb49dac19879a1e98dc75706e1963a11665a31c80161a6ff9580b5e2c0ec50de7e168860cde647488c67d2bb5bfd1418b9f4637c9db2f3d68d1b49bcfb47 SHA512 824ba1a9125af8fc23f402ab4de26c82250dad7be0080e0050585ad955337801393792c01ed3affa8a25551fa07b3caaedecde1889401293d415249e70a72705
+DIST ansi-0.1.5.tar.gz 4606 BLAKE2B 5f88319f05262511e99c8385946b61e2ed7219217ae8e811e8c1762fbd402f2fcaf69bcd6e4caf35d1f982afebcce5a98c721e2598032891382010ff7b928c55 SHA512 03365aca71b4966ca0c78b1563400afe414c86288b4e8ede969fb9c79cd4da4722de8cedae4e86c2f536f82eda42845482e041a396cb33852d3e4ff639dbbb64
diff --git a/dev-python/ansi/ansi-0.1.5.ebuild b/dev-python/ansi/ansi-0.1.5.ebuild
new file mode 100644
index 000000000000..ab480d057429
--- /dev/null
+++ b/dev-python/ansi/ansi-0.1.5.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit distutils-r1
+
+DESCRIPTION="ANSI cursor movement and graphics in Python"
+HOMEPAGE="https://github.com/tehmaze/ansi"
+SRC_URI="https://github.com/tehmaze/${PN}/archive/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${PN}-${P}"