summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ansible-runner/ansible-runner-1.4.7-r1.ebuild')
-rw-r--r--dev-python/ansible-runner/ansible-runner-1.4.7-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/ansible-runner/ansible-runner-1.4.7-r1.ebuild b/dev-python/ansible-runner/ansible-runner-1.4.7-r1.ebuild
new file mode 100644
index 000000000000..2997346f5f9b
--- /dev/null
+++ b/dev-python/ansible-runner/ansible-runner-1.4.7-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A tool and python library that helps when interfacing with Ansible"
+HOMEPAGE="https://github.com/ansible/ansible-runner"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RDEPEND="
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/python-daemon[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e 's|find_packages()|find_packages(exclude=["test", "test.*"])|' -i setup.py || die
+ distutils-r1_python_prepare_all
+}