summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/asn1crypto/asn1crypto-1.4.0.ebuild')
-rw-r--r--dev-python/asn1crypto/asn1crypto-1.4.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/asn1crypto/asn1crypto-1.4.0.ebuild b/dev-python/asn1crypto/asn1crypto-1.4.0.ebuild
new file mode 100644
index 000000000000..9803ec895c27
--- /dev/null
+++ b/dev-python/asn1crypto/asn1crypto-1.4.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python ASN.1 library with a focus on performance and a pythonic API"
+HOMEPAGE="https://github.com/wbond/asn1crypto/ https://pypi.org/project/asn1crypto/"
+# pypi tarball does not have tests
+SRC_URI="https://github.com/wbond/asn1crypto/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+distutils_enable_tests unittest