summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/astunparse')
-rw-r--r--dev-python/astunparse/Manifest1
-rw-r--r--dev-python/astunparse/astunparse-1.6.3.ebuild32
-rw-r--r--dev-python/astunparse/files/astunparse-1.6.2-tests.patch23
-rw-r--r--dev-python/astunparse/files/astunparse-1.6.3-py39.patch74
-rw-r--r--dev-python/astunparse/metadata.xml15
5 files changed, 0 insertions, 145 deletions
diff --git a/dev-python/astunparse/Manifest b/dev-python/astunparse/Manifest
deleted file mode 100644
index 82d2f7d59c40..000000000000
--- a/dev-python/astunparse/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST astunparse-1.6.3.tar.gz 18290 BLAKE2B d7e6fa3ba58c6e112eb84720832890f4515b1c4ed420587565cdff37da893c07eefd0b9eb00795a3eb08bf56834d65150298a6be65e524b0c267c38e6f9c20d1 SHA512 12e99b32524e551494d3053a57aeb646bca8a96a9aa17b0737e6dace6c11874e2e7633d82197cacc0b55622bea637030344ab45c8db57ef244bd63663799d2e9
diff --git a/dev-python/astunparse/astunparse-1.6.3.ebuild b/dev-python/astunparse/astunparse-1.6.3.ebuild
deleted file mode 100644
index 62de148afa6a..000000000000
--- a/dev-python/astunparse/astunparse-1.6.3.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Astun parser for python"
-HOMEPAGE="https://github.com/simonpercivall/astunparse"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv ~sparc x86"
-
-RDEPEND="
- >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
- >=dev-python/wheel-0.23.0[${PYTHON_USEDEP}]
-"
-PATCHES=(
- "${FILESDIR}/astunparse-1.6.2-tests.patch"
- # from Fedora
- "${FILESDIR}/${P}-py39.patch"
-)
-
-distutils_enable_tests setup.py
-
-python_install_all() {
- distutils-r1_python_install_all
- dodoc *.rst
-}
diff --git a/dev-python/astunparse/files/astunparse-1.6.2-tests.patch b/dev-python/astunparse/files/astunparse-1.6.2-tests.patch
deleted file mode 100644
index b82c22831a9b..000000000000
--- a/dev-python/astunparse/files/astunparse-1.6.2-tests.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff --git a/tests/common.py b/tests/common.py
-index 95b9755..41123de 100644
---- a/tests/common.py
-+++ b/tests/common.py
-@@ -1,6 +1,7 @@
- import codecs
- import os
- import sys
-+import site
- if sys.version_info < (2, 7):
- import unittest2 as unittest
- else:
-@@ -175,9 +176,7 @@ class AstunparseCommonTestCase:
- def check_roundtrip(self, code1, filename="internal", mode="exec"):
- raise NotImplementedError()
-
-- test_directories = [
-- os.path.join(getattr(sys, 'real_prefix', sys.prefix),
-- 'lib', 'python%s.%s' % sys.version_info[:2])]
-+ test_directories = [os.path.dirname(d) for d in site.getsitepackages()]
-
- def test_files(self):
- names = []
diff --git a/dev-python/astunparse/files/astunparse-1.6.3-py39.patch b/dev-python/astunparse/files/astunparse-1.6.3-py39.patch
deleted file mode 100644
index ab8116a559ac..000000000000
--- a/dev-python/astunparse/files/astunparse-1.6.3-py39.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-From 0388a0d2f42401dcedf7f89d3c291cfed3e4a3d5 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
-Date: Wed, 8 Jul 2020 20:15:57 +0200
-Subject: [PATCH 1/2] Adapt dump() behavior to match ast.dump() on Python 3.9+
-
-In Python 3.9+, ast.dump() omits optional fields/attributes from the output if
-their value is None. Such defaults are defined as class attributes.
-
-See https://bugs.python.org/issue36287
-And https://github.com/python/cpython/pull/18843
-
-This patch does not change the output on previous Python versions,
-because the class attributes are missing there.
-
-Fixes https://github.com/simonpercivall/astunparse/issues/56
----
- lib/astunparse/printer.py | 7 ++++++-
- 1 file changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/lib/astunparse/printer.py b/lib/astunparse/printer.py
-index 92d64f7..7a33deb 100644
---- a/lib/astunparse/printer.py
-+++ b/lib/astunparse/printer.py
-@@ -4,6 +4,9 @@
- import six
-
-
-+_NOPE = object()
-+
-+
- class Printer(ast.NodeVisitor):
-
- def __init__(self, file=sys.stdout, indent=" "):
-@@ -19,6 +22,7 @@ def write(self, text):
- self.f.write(six.text_type(text))
-
- def generic_visit(self, node):
-+ cls = type(node)
-
- if isinstance(node, list):
- nodestart = "["
-@@ -27,7 +31,8 @@ def generic_visit(self, node):
- else:
- nodestart = type(node).__name__ + "("
- nodeend = ")"
-- children = [(name + "=", value) for name, value in ast.iter_fields(node)]
-+ children = [(name + "=", value) for name, value in ast.iter_fields(node)
-+ if not (value is None and getattr(cls, name, _NOPE) is None)]
-
- if len(children) > 1:
- self.indentation += 1
-
-From ea2b578a1b653e73696db2392b8e3d5bf75dadc7 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
-Date: Wed, 8 Jul 2020 20:21:17 +0200
-Subject: [PATCH 2/2] Test and support Python 3.9
-
----
- setup.py | 1 +
- tox.ini | 2 +-
- 2 files changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/setup.py b/setup.py
-index e5a277a..29b384b 100755
---- a/setup.py
-+++ b/setup.py
-@@ -52,6 +52,7 @@ def read_version():
- 'Programming Language :: Python :: 3.6',
- 'Programming Language :: Python :: 3.7',
- 'Programming Language :: Python :: 3.8',
-+ 'Programming Language :: Python :: 3.9',
- 'Topic :: Software Development :: Code Generators',
- ],
- test_suite='tests',
diff --git a/dev-python/astunparse/metadata.xml b/dev-python/astunparse/metadata.xml
deleted file mode 100644
index ca0a873ac6ed..000000000000
--- a/dev-python/astunparse/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>williamh@gentoo.org</email>
- <name>William Hubbs</name>
- </maintainer>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">astunparse</remote-id>
- </upstream>
-</pkgmetadata>