summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/atpublic/atpublic-2.1.2.ebuild')
-rw-r--r--dev-python/atpublic/atpublic-2.1.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/atpublic/atpublic-2.1.2.ebuild b/dev-python/atpublic/atpublic-2.1.2.ebuild
new file mode 100644
index 000000000000..81e2361f4d03
--- /dev/null
+++ b/dev-python/atpublic/atpublic-2.1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="A decorator to populate __all__ and the module globals"
+HOMEPAGE="https://gitlab.com/warsaw/public"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' python3_7)"
+BDEPEND="
+ test? ( dev-python/sybil[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov=public::' setup.cfg || die
+ distutils-r1_src_prepare
+}