summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/attrs/attrs-18.1.0.ebuild')
-rw-r--r--dev-python/attrs/attrs-18.1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/attrs/attrs-18.1.0.ebuild b/dev-python/attrs/attrs-18.1.0.ebuild
new file mode 100644
index 000000000000..b9f32fe9dd4d
--- /dev/null
+++ b/dev-python/attrs/attrs-18.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Attributes without boilerplate"
+HOMEPAGE="
+ https://github.com/hynek/attrs
+ https://attrs.readthedocs.org/
+ https://pypi.org/project/attrs/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ >=dev-python/hypothesis-3.6.0[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die "tests failed with ${EPYTHON}"
+}