summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/Manifest2
-rw-r--r--dev-python/autopep8/autopep8-1.5.7.ebuild29
-rw-r--r--dev-python/autopep8/autopep8-2.1.0.ebuild29
-rw-r--r--dev-python/autopep8/autopep8-9999.ebuild26
-rw-r--r--dev-python/autopep8/metadata.xml2
5 files changed, 47 insertions, 41 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index 6d6433b471a7..7fe7d3ab4421 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -1 +1 @@
-DIST autopep8-1.5.7.tar.gz 121537 BLAKE2B 06f107cab210258fe71b8e912312520797122fd38e3e67fa0d6cf640806690e1255fec63c74c11ec39952a4a50964a3f622ca1166d29299c4f7a7031a1013202 SHA512 b8fb8b63400e74ea978f576cb47c99b0a4bb15a5d1cfeb6ffc25d2ecdad301762f99ddff5c75af3900b3560797d9289a15bbb87ddcf74077d39bde0abadd4da7
+DIST autopep8-2.1.0.tar.gz 88891 BLAKE2B 60bd5e9a177d8bdb741b37884bb3ef170fb59664b740beb1b1f38df021dfb7916f2cecdb2e20b6363c2abcc110f9f36902dbccd7f06ddf56f090ccb36149fb19 SHA512 f694a506646b4bc4932fb07cf1c989897e7db3fc9b65dc90886fa657b163dfcbad4c16bb911a2e399a4623b167b313d32213762d3e21e20bff27b6fe2a5abc59
diff --git a/dev-python/autopep8/autopep8-1.5.7.ebuild b/dev-python/autopep8/autopep8-1.5.7.ebuild
deleted file mode 100644
index e0ed8e204c7f..000000000000
--- a/dev-python/autopep8/autopep8-1.5.7.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
-HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~alpha amd64 ~arm64 ~ia64 ppc sparc x86 ~amd64-linux ~x86-linux"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-
-RDEPEND="
- >=dev-python/pycodestyle-2.7.0[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]"
-BDEPEND="test? ( dev-python/pydiff[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests setup.py
diff --git a/dev-python/autopep8/autopep8-2.1.0.ebuild b/dev-python/autopep8/autopep8-2.1.0.ebuild
new file mode 100644
index 000000000000..1b82191667cc
--- /dev/null
+++ b/dev-python/autopep8/autopep8-2.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="
+ https://github.com/hhatto/autopep8/
+ https://pypi.org/project/autopep8/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm64 ~ia64 ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/pycodestyle-2.11.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/autopep8/autopep8-9999.ebuild b/dev-python/autopep8/autopep8-9999.ebuild
index 11848b6f772e..1d564bd34c07 100644
--- a/dev-python/autopep8/autopep8-9999.ebuild
+++ b/dev-python/autopep8/autopep8-9999.ebuild
@@ -1,29 +1,35 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
-HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
+HOMEPAGE="
+ https://github.com/hhatto/autopep8/
+ https://pypi.org/project/autopep8/
+"
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
inherit git-r3
else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+ inherit pypi
+ KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
LICENSE="MIT"
SLOT="0"
RDEPEND="
- >=dev-python/pycodestyle-2.6.0[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]"
-BDEPEND="test? ( dev-python/pydiff[${PYTHON_USEDEP}] )"
+ >=dev-python/pycodestyle-2.10[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
-distutils_enable_tests setup.py
+distutils_enable_tests pytest
diff --git a/dev-python/autopep8/metadata.xml b/dev-python/autopep8/metadata.xml
index 560792cb09b5..ce9b652752b1 100644
--- a/dev-python/autopep8/metadata.xml
+++ b/dev-python/autopep8/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>python@gentoo.org</email>