summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/autoprop/autoprop-3.0.0.ebuild')
-rw-r--r--dev-python/autoprop/autoprop-3.0.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/autoprop/autoprop-3.0.0.ebuild b/dev-python/autoprop/autoprop-3.0.0.ebuild
new file mode 100644
index 000000000000..6a1d42d9b3be
--- /dev/null
+++ b/dev-python/autoprop/autoprop-3.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Infer properties from accessor methods"
+HOMEPAGE="
+ https://github.com/kalekundert/autoprop/
+ https://pypi.org/project/autoprop/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ dev-python/signature_dispatch[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest