summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/aws-xray-sdk-python')
-rw-r--r--dev-python/aws-xray-sdk-python/Manifest1
-rw-r--r--dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.10.0.ebuild79
-rw-r--r--dev-python/aws-xray-sdk-python/files/aws-xray-sdk-python-2.8.0-fix-py3.10-loops.patch36
-rw-r--r--dev-python/aws-xray-sdk-python/metadata.xml18
4 files changed, 0 insertions, 134 deletions
diff --git a/dev-python/aws-xray-sdk-python/Manifest b/dev-python/aws-xray-sdk-python/Manifest
deleted file mode 100644
index 4eb05452e07a..000000000000
--- a/dev-python/aws-xray-sdk-python/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST aws-xray-sdk-python-2.10.0.gh.tar.gz 270819 BLAKE2B caed5f5b92bdc25e0006663838549c9e9a85474829cce03f612ef4b9a36fce38460606e000c65bb140f7250225426bece2e8bc624a430bdfdcd4fc8808842aac SHA512 f5b4d08f5876cab2e833a763b1da52b6de1e3ca2c746b234a1b013f674155ec31686a6710225e411458f27ca096f68ee6413c8d1c360d5a326f1be94287d09b7
diff --git a/dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.10.0.ebuild b/dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.10.0.ebuild
deleted file mode 100644
index fa39672112ff..000000000000
--- a/dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.10.0.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="AWS X-Ray SDK for Python"
-HOMEPAGE="
- https://github.com/aws/aws-xray-sdk-python/
- https://pypi.org/project/aws-xray-sdk/
-"
-SRC_URI="
- https://github.com/aws/aws-xray-sdk-python/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/botocore-1.12.122[${PYTHON_USEDEP}]
- dev-python/wrapt[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/bottle[${PYTHON_USEDEP}]
- dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/sqlalchemy-1.4[${PYTHON_USEDEP}]
- dev-python/webtest[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.8.0-fix-py3.10-loops.patch"
-)
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x DJANGO_SETTINGS_MODULE=tests.ext.django.app.settings
- local -x AWS_SECRET_ACCESS_KEY=fake_key
- local -x AWS_ACCESS_KEY_ID=fake_id
-
- local EPYTEST_DESELECT=(
- # Internet access
- tests/test_patcher.py::test_external_file
- tests/test_patcher.py::test_external_module
- tests/test_patcher.py::test_external_submodules_full
- tests/test_patcher.py::test_external_submodules_ignores_file
- tests/test_patcher.py::test_external_submodules_ignores_module
- # benchmark
- tests/test_local_sampling_benchmark.py
- )
- local EPYTEST_IGNORE=(
- # unpackaged deps
- tests/ext/aiobotocore
- tests/ext/pg8000
- tests/ext/psycopg2
- tests/ext/pymysql
- tests/ext/pynamodb
- tests/ext/sqlalchemy_core/test_postgres.py
- tests/ext/django/test_db.py
- # Internet access
- tests/ext/httplib
- tests/ext/requests
- # requires old package vesions
- tests/ext/django
- tests/ext/aiohttp
- )
-
- epytest -p no:django
-}
diff --git a/dev-python/aws-xray-sdk-python/files/aws-xray-sdk-python-2.8.0-fix-py3.10-loops.patch b/dev-python/aws-xray-sdk-python/files/aws-xray-sdk-python-2.8.0-fix-py3.10-loops.patch
deleted file mode 100644
index cde91a8d0cda..000000000000
--- a/dev-python/aws-xray-sdk-python/files/aws-xray-sdk-python-2.8.0-fix-py3.10-loops.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff --git a/tests/ext/aiohttp/test_middleware.py b/tests/ext/aiohttp/test_middleware.py
-index c8b2333..4f8cac6 100644
---- a/tests/ext/aiohttp/test_middleware.py
-+++ b/tests/ext/aiohttp/test_middleware.py
-@@ -279,8 +279,7 @@ async def test_concurrent(test_client, loop, recorder):
-
- await asyncio.wait([get_delay(), get_delay(), get_delay(),
- get_delay(), get_delay(), get_delay(),
-- get_delay(), get_delay(), get_delay()],
-- loop=loop)
-+ get_delay(), get_delay(), get_delay()])
-
- # Ensure all ID's are different
- ids = [item.id for item in recorder.emitter.local]
-diff --git a/tests/test_async_local_storage.py b/tests/test_async_local_storage.py
-index b43cc0e..4b13ffd 100644
---- a/tests/test_async_local_storage.py
-+++ b/tests/test_async_local_storage.py
-@@ -19,7 +19,7 @@ def test_localstorage_isolation(loop):
- random_int = random.random()
- local_storage.randint = random_int
-
-- await asyncio.sleep(0.0, loop=loop)
-+ await asyncio.sleep(0.0)
-
- current_random_int = local_storage.randint
- assert random_int == current_random_int
-@@ -30,7 +30,7 @@ def test_localstorage_isolation(loop):
-
- # Run loads of concurrent tasks
- results = loop.run_until_complete(
-- asyncio.wait([_test() for _ in range(0, 100)], loop=loop)
-+ asyncio.wait([_test() for _ in range(0, 100)])
- )
- results = [item.result() for item in results[0]]
-
diff --git a/dev-python/aws-xray-sdk-python/metadata.xml b/dev-python/aws-xray-sdk-python/metadata.xml
deleted file mode 100644
index 925c16c14d43..000000000000
--- a/dev-python/aws-xray-sdk-python/metadata.xml
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>zmedico@gentoo.org</email>
- <name>Zac Medico</name>
- </maintainer>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <stabilize-allarches/>
- <upstream>
- <remote-id type="github">aws/aws-xray-sdk-python</remote-id>
- <remote-id type="pypi">aws-xray-sdk</remote-id>
- <bugs-to>https://github.com/aws/aws-xray-sdk-python/issues</bugs-to>
- </upstream>
-</pkgmetadata>