summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/awxkit')
-rw-r--r--dev-python/awxkit/Manifest2
-rw-r--r--dev-python/awxkit/awxkit-21.11.0.ebuild47
-rw-r--r--dev-python/awxkit/awxkit-21.12.0.ebuild48
3 files changed, 0 insertions, 97 deletions
diff --git a/dev-python/awxkit/Manifest b/dev-python/awxkit/Manifest
index 1f1ab27778bd..131107a573ce 100644
--- a/dev-python/awxkit/Manifest
+++ b/dev-python/awxkit/Manifest
@@ -1,3 +1 @@
DIST awx-21.13.0.gh.tar.gz 16221713 BLAKE2B 7e875efced94fb22d782deb9583fddfa13e10079a202298d0ca05af58048d4bf70480aacec7f0e3c408c9600fff126886cb6912bdadb3f48a33932c9debd2344 SHA512 90628347f71663d4e13fed2cc529b3bda858d07130b74593582e82e19b8c6e6049c9ad6cdd419e4efa4bd366771e993665ef4527f5de336edd5f020c9a93ca7a
-DIST awxkit-21.11.0.gh.tar.gz 16206681 BLAKE2B 738fae8028f4b576c36860002f802280263ec2731e91047b9f5f1a7aba28b5548b2a8add4659f9021c805a4bda0361e96c310c63b6bdf33c47705fbc222a3a5e SHA512 7c2e07f2951738bc04ce7cdc8c3e6fba3becaa70daa3de5c31fa931a7240b76001af791e819005b7c651c781e3b42c17850a79da059b2fc260efb8029f29033f
-DIST awxkit-21.12.0.gh.tar.gz 16218917 BLAKE2B 6e017bfb5707d6ec4107ec151311b133323c816da1aac1fe2441e639fcf22fe19e38f6c4dd81e29c63d5c7ff8f81ee62d6c4cfbc1500c0827e5b68b6e9f7187c SHA512 be1db2e5c51649910fa09659d2f1072f55c39a95f28c8a5ebd9490c43123ae90fbff242914c803e3882fa60ea07b39009dec9d27c56d005ab6333431e62a0576
diff --git a/dev-python/awxkit/awxkit-21.11.0.ebuild b/dev-python/awxkit/awxkit-21.11.0.ebuild
deleted file mode 100644
index 66765826e930..000000000000
--- a/dev-python/awxkit/awxkit-21.11.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Command line interface for Ansible AWX"
-HOMEPAGE="
- https://github.com/ansible/awx/
- https://pypi.org/project/awxkit/
-"
-SRC_URI="
- https://github.com/ansible/awx/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-S="${WORKDIR}/awx-${PV}/awxkit"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- dev-python/websocket-client[${PYTHON_USEDEP}]
- dev-python/pyjwt[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
- sed -e 's|websocket-client==[[:digit:]\.]*|websocket-client|' \
- -e "/'clean'/d" \
- -i setup.py || die
- distutils-r1_src_prepare
-}
diff --git a/dev-python/awxkit/awxkit-21.12.0.ebuild b/dev-python/awxkit/awxkit-21.12.0.ebuild
deleted file mode 100644
index 60237928f391..000000000000
--- a/dev-python/awxkit/awxkit-21.12.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Command line interface for Ansible AWX"
-HOMEPAGE="
- https://github.com/ansible/awx/
- https://pypi.org/project/awxkit/
-"
-SRC_URI="
- https://github.com/ansible/awx/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-S="${WORKDIR}/awx-${PV}/awxkit"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- dev-python/websocket-client[${PYTHON_USEDEP}]
- dev-python/pyjwt[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
- printf '%s\n' "${PV}" > VERSION || die
-
- sed -e 's|websocket-client==[[:digit:]\.]*|websocket-client|' \
- -e "/'clean'/d" \
- -i setup.py || die
- distutils-r1_src_prepare
-}