summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bandit')
-rw-r--r--dev-python/bandit/Manifest5
-rw-r--r--dev-python/bandit/bandit-1.6.2-r1.ebuild56
-rw-r--r--dev-python/bandit/bandit-1.7.0.ebuild49
-rw-r--r--dev-python/bandit/bandit-1.7.8.ebuild44
-rw-r--r--dev-python/bandit/metadata.xml7
5 files changed, 51 insertions, 110 deletions
diff --git a/dev-python/bandit/Manifest b/dev-python/bandit/Manifest
index d18c2927dfdb..c2d80f5c82ee 100644
--- a/dev-python/bandit/Manifest
+++ b/dev-python/bandit/Manifest
@@ -1,4 +1 @@
-DIST bandit-1.6.2.tar.gz 498567 BLAKE2B ab7885df634ff8258fc7620523b56995cb2f262f4290193a9063e216f66ba8ecb31ec17f09d0b72a0472923266953c46e47e74fcdfb39784873738c033e00c6c SHA512 9facce98411ceb9e33e5a978ca4aad2dab541ffe215e480806ac921b7f7067572445d8e32e8d473ef30bb57155b72b2ffd4e06d458a3da82e2a9fb1b1d8a4b9f
-DIST bandit-1.6.2_py38-1.patch 3892 BLAKE2B 750160be3d234b0d638307e74fd130921f43f460edca8d0ef0f9a98f34db709e0649b1e481668abd094942fa05ee710b82b3161fd82bc56bb0f5e73d90a6e70f SHA512 dc1e55bdcbf180e70757dd92aa590fe1348d84a2143af73e48c35c62864cf0720f6b055482eb274a4261adff37c84f998c75916b8ab70d99264bd88d09611e06
-DIST bandit-1.6.2_py38-2.patch 3724 BLAKE2B 8ce857419d99b059ce1b28aba7c04218397cad82f0fdb6e7eb3e57f698d6360de7b0f4402c40540e41d510db1aa0b75e006e0e15a20a8c5534b7e5a3cf78a0e8 SHA512 25f73b087b296867556d9b9bb7f789a4df64bd2930509086bc24312c43a3a98209d63a5b00009e31fd2653e89c85e62849c7af6ba044abc10c5789a6e3d9a968
-DIST bandit-1.7.0.tar.gz 506225 BLAKE2B 6e2383576b2091ab98757381bfd5915331fc7b08a251e817a6964d963de60b070f7c4dc7958dd366cf95333f4abc157e80433490ab8b923580cb45d855c13092 SHA512 c51af7ab4c667c376a11f142fa35881a776d420bd3ef41421bd29a713e0b56bbf1622e24cd878e24f57594f03d06b7c2b8258fcf34f57e3a68df4200a34becdc
+DIST bandit-1.7.8.tar.gz 1983678 BLAKE2B 7891c6f3cd893c0abd9becfb648284cbc393c5d0d1be6d9bf9934fcd33038ac34afd40e3d5cb4ef2d3389cb33f73d719de21cd9ef3acf8f64c73e41a11fc4fb6 SHA512 a9fb2e052018eaff77617f0b9aded2e42f2e50f8ff08d273597a686376e2f621f0f7be7efbb273380155a8bbf2aed4c7f15e48b5652544122d5b9766a4dc1cc1
diff --git a/dev-python/bandit/bandit-1.6.2-r1.ebuild b/dev-python/bandit/bandit-1.6.2-r1.ebuild
deleted file mode 100644
index e455e7f97a6a..000000000000
--- a/dev-python/bandit/bandit-1.6.2-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="A security linter from OpenStack Security"
-HOMEPAGE="https://github.com/PyCQA/bandit"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
- https://github.com/PyCQA/bandit/commit/45494c94d59eea5ddbe0204f3781b90108cbde30.patch -> ${P}_py38-1.patch
- https://github.com/PyCQA/bandit/commit/3d0824676974e7e2e9635c10bc4f12e261f1dbdf.patch -> ${P}_py38-2.patch
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~s390 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- test? (
- >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
- !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/hacking-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/stestr-1.0.0
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
- >=dev-python/beautifulsoup-4.6.0[${PYTHON_USEDEP}]
- >=dev-python/pylint-1.4.5[${PYTHON_USEDEP}]
- )"
-RDEPEND="
- >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/GitPython-1.0.1[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]"
-
-python_prepare() {
- sed -i 's/yaml.load/yaml.safe_load/g' tests/unit/formatters/test_yaml.py || die
- eapply "${DISTDIR}/${P}_py38-1.patch"
- eapply "${DISTDIR}/${P}_py38-2.patch"
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- distutils_install_for_testing
- stestr init
- stestr run || die
-}
diff --git a/dev-python/bandit/bandit-1.7.0.ebuild b/dev-python/bandit/bandit-1.7.0.ebuild
deleted file mode 100644
index 2bd9f1e75056..000000000000
--- a/dev-python/bandit/bandit-1.7.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="A security linter from OpenStack Security"
-HOMEPAGE="https://github.com/PyCQA/bandit"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~s390 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- test? (
- >=dev-python/coverage-4.5.4[${PYTHON_USEDEP}]
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/hacking-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/mock-3.0.5[${PYTHON_USEDEP}]
- >=dev-python/stestr-2.5.0
- >=dev-python/testscenarios-0.5.0[${PYTHON_USEDEP}]
- >=dev-python/testtools-2.3.0[${PYTHON_USEDEP}]
- >=dev-python/beautifulsoup-4.8.0[${PYTHON_USEDEP}]
- >=dev-python/pylint-1.9.4[${PYTHON_USEDEP}]
- )"
-RDEPEND="
- >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/GitPython-1.0.1[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]"
-
-python_prepare() {
- sed -i 's/yaml.load/yaml.safe_load/g' tests/unit/formatters/test_yaml.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- distutils_install_for_testing
- stestr init
- stestr run || die
-}
diff --git a/dev-python/bandit/bandit-1.7.8.ebuild b/dev-python/bandit/bandit-1.7.8.ebuild
new file mode 100644
index 000000000000..27c35a502ccb
--- /dev/null
+++ b/dev-python/bandit/bandit-1.7.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A security linter from OpenStack Security"
+HOMEPAGE="
+ https://github.com/PyCQA/bandit/
+ https://pypi.org/project/bandit/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 arm64 ~riscv x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/GitPython-3.1.30[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/beautifulsoup4-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/pylint-1.9.4[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.3.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.10)
+ )
+"
+
+distutils_enable_tests unittest
diff --git a/dev-python/bandit/metadata.xml b/dev-python/bandit/metadata.xml
index 3a9cff4a6b50..a083c37dbb02 100644
--- a/dev-python/bandit/metadata.xml
+++ b/dev-python/bandit/metadata.xml
@@ -1,13 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>prometheanfire@gentoo.org</email>
<name>Matthew Thode</name>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
<longdescription lang="en">
Bandit is a tool designed to find common security issues in Python code. To do this Bandit processes each file, builds an AST from it, and runs appropriate plugins against the AST nodes. Once Bandit has finished scanning all the files it generates a report.
</longdescription>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">bandit</remote-id>
<remote-id type="github">PyCQA/bandit</remote-id>