summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bcrypt/bcrypt-3.1.2.ebuild')
-rw-r--r--dev-python/bcrypt/bcrypt-3.1.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/bcrypt/bcrypt-3.1.2.ebuild b/dev-python/bcrypt/bcrypt-3.1.2.ebuild
new file mode 100644
index 000000000000..1edbf5542a85
--- /dev/null
+++ b/dev-python/bcrypt/bcrypt-3.1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Modern password hashing for software and servers"
+HOMEPAGE="https://github.com/pyca/bcrypt/ https://pypi.python.org/pypi/bcrypt/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep '>=virtual/pypy-2.6.0' pypy )
+ "
+RDEPEND="
+ $(python_gen_cond_dep '>=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep '>=virtual/pypy-2.6.0' pypy )
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ !dev-python/py-bcrypt"
+
+# The testsuite is not included in the tarball