summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/beautifulsoup4')
-rw-r--r--dev-python/beautifulsoup4/Manifest3
-rw-r--r--dev-python/beautifulsoup4/beautifulsoup4-4.10.0.ebuild24
-rw-r--r--dev-python/beautifulsoup4/beautifulsoup4-4.12.3.ebuild39
-rw-r--r--dev-python/beautifulsoup4/beautifulsoup4-4.9.3.ebuild32
4 files changed, 40 insertions, 58 deletions
diff --git a/dev-python/beautifulsoup4/Manifest b/dev-python/beautifulsoup4/Manifest
index 4dede2d8d2dd..ac78ef0aa60f 100644
--- a/dev-python/beautifulsoup4/Manifest
+++ b/dev-python/beautifulsoup4/Manifest
@@ -1,2 +1 @@
-DIST beautifulsoup4-4.10.0.tar.gz 399890 BLAKE2B 61f044064a81e94b64a72fd49cca164faa05442bc76f897c8a7fa4481acca039bcb9e4f7a1853a7155504fa25e56c518806d8af016369bc37316ecb95b59d7d3 SHA512 92be99ed0fd479b86519395143516e28f7b80f54a8251223d6e7b88dc98f8dfca9585079f5f1d89bfe68f577de3dff433711642486303203f46bc76754959a18
-DIST beautifulsoup4-4.9.3.tar.gz 376031 BLAKE2B fbe2139f288eee978c3f665c7640f66c6c51b857a186f6a8ace02b36effa1552f1cbea9e3744e0a46a65a06e6cdbd9203832e0ecd86b61406b933f9bd83d37b8 SHA512 e3cb6258bd7c51f12128fa8ee5948fb3566163ae233fac2dda21bab7772ab8dbb384d920b0ea138ef9921307b48f89cee3a9bf6111dfc8903d917ee7af365f34
+DIST beautifulsoup4-4.12.3.tar.gz 581181 BLAKE2B dac85b2d56ad1d2faf040def2141cb7a7ca68def7fc48fab18e11c23878795fcecfdd43058e70229e014e23e67f56a55160aa4ba08bab4b3d955bd10a07c8168 SHA512 b5b6cc9f64a97fa52b9a2ee1265aa215db476e705d3d79e49301de7e8d36c56c96924cb440eec0715f7ec75c5ddf4c1ade9d6cef7cdc9bf9e37125ac6eb50837
diff --git a/dev-python/beautifulsoup4/beautifulsoup4-4.10.0.ebuild b/dev-python/beautifulsoup4/beautifulsoup4-4.10.0.ebuild
deleted file mode 100644
index 975d9e35d6bd..000000000000
--- a/dev-python/beautifulsoup4/beautifulsoup4-4.10.0.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
-HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
-
-RDEPEND="
- dev-python/soupsieve[${PYTHON_USEDEP}]
- dev-python/html5lib[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests unittest
-distutils_enable_sphinx doc/source
diff --git a/dev-python/beautifulsoup4/beautifulsoup4-4.12.3.ebuild b/dev-python/beautifulsoup4/beautifulsoup4-4.12.3.ebuild
new file mode 100644
index 000000000000..fa1f017754ba
--- /dev/null
+++ b/dev-python/beautifulsoup4/beautifulsoup4-4.12.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="
+ https://www.crummy.com/software/BeautifulSoup/bs4/
+ https://pypi.org/project/beautifulsoup4/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/soupsieve-1.3[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+# bs4 prefers cchardet > chardet > charset-normalizer
+# however, charset-normalizer causes test failures, so force the other two
+# dev-python/chardet[${PYTHON_USEDEP}]
+BDEPEND="
+ test? (
+ || (
+ dev-python/cchardet[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc/source
diff --git a/dev-python/beautifulsoup4/beautifulsoup4-4.9.3.ebuild b/dev-python/beautifulsoup4/beautifulsoup4-4.9.3.ebuild
deleted file mode 100644
index c9b54e80fbf0..000000000000
--- a/dev-python/beautifulsoup4/beautifulsoup4-4.9.3.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
-HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- dev-python/soupsieve[${PYTHON_USEDEP}]
- dev-python/html5lib[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
-"
-BDEPEND="
- <dev-python/setuptools-58[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests nose
-distutils_enable_sphinx doc/source
-
-python_test() {
- nosetests --verbose -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"
-}