summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bitarray')
-rw-r--r--dev-python/bitarray/Manifest2
-rw-r--r--dev-python/bitarray/bitarray-2.9.2.ebuild (renamed from dev-python/bitarray/bitarray-2.6.0.ebuild)12
-rw-r--r--dev-python/bitarray/metadata.xml20
3 files changed, 17 insertions, 17 deletions
diff --git a/dev-python/bitarray/Manifest b/dev-python/bitarray/Manifest
index b3b4b2be7db3..09be655b3ee4 100644
--- a/dev-python/bitarray/Manifest
+++ b/dev-python/bitarray/Manifest
@@ -1 +1 @@
-DIST bitarray-2.6.0.tar.gz 102780 BLAKE2B aaabaa2e59f54970087224a569e793705d8753901b0fc93e9a40a0ae2466940768e8f547fe25b32c0194893bf5baa77851bcf1608d3f18d9b1d5c11f70579dec SHA512 c4deeee54af884dc9200ffe80a7788db64478383f1210ab7e3aa2adf94809d2e38ae817bf11611f49373b12ebfe23cbe5287786da08475cf9761fd8345c554d7
+DIST bitarray-2.9.2.tar.gz 132825 BLAKE2B dcd574f5273a876e8010513a433fbf657a0cdb37899b470ec4ba07d64af075a6d1660390e6dc040361537d115d4dc2abb9e21aa26601b5d8d9511a40408f7fc4 SHA512 fe7ea6fa35de53a0cbd1042cf7a596080690b94771d160b6659f085c969d29d8f816ffda14d3b3a16fb398573410cfdb53183704cf846e94af942b6dad9708fb
diff --git a/dev-python/bitarray/bitarray-2.6.0.ebuild b/dev-python/bitarray/bitarray-2.9.2.ebuild
index 7f20ddf0cdf8..372329f8b57d 100644
--- a/dev-python/bitarray/bitarray-2.6.0.ebuild
+++ b/dev-python/bitarray/bitarray-2.9.2.ebuild
@@ -1,23 +1,23 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{10..13} )
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="Efficient arrays of booleans -- C extension"
HOMEPAGE="
https://github.com/ilanschnell/bitarray/
https://pypi.org/project/bitarray/
"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
-SLOT="0"
LICENSE="PSF-2"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 x86 ~amd64-linux ~x86-linux"
python_test() {
"${EPYTHON}" bitarray/test_bitarray.py -v || die "Tests fail with ${EPYTHON}"
diff --git a/dev-python/bitarray/metadata.xml b/dev-python/bitarray/metadata.xml
index fb88a275d37c..89e2ff60e023 100644
--- a/dev-python/bitarray/metadata.xml
+++ b/dev-python/bitarray/metadata.xml
@@ -10,16 +10,16 @@
<name>Python</name>
</maintainer>
<longdescription>
-This module provides an object type which efficiently represents an array of
-booleans. Bitarrays are sequence types and behave very much like usual lists.
-Eight bits are represented by one byte in a contiguous block of memory. The
-user can select between two representations; little-endian and big-endian.
-Most of the functionality is implemented in C. Methods for accessing the
-machine representation are provided. This can be useful when bit level access
-to binary files is required, such as portable bitmap image files (.pbm). Also,
-when dealing with compressed data which uses variable bit length encoding,
-you may find this module useful.
-</longdescription>
+ This module provides an object type which efficiently represents an array of
+ booleans. Bitarrays are sequence types and behave very much like usual lists.
+ Eight bits are represented by one byte in a contiguous block of memory. The
+ user can select between two representations; little-endian and big-endian.
+ Most of the functionality is implemented in C. Methods for accessing the
+ machine representation are provided. This can be useful when bit level access
+ to binary files is required, such as portable bitmap image files (.pbm). Also,
+ when dealing with compressed data which uses variable bit length encoding,
+ you may find this module useful.
+ </longdescription>
<upstream>
<remote-id type="pypi">bitarray</remote-id>
<remote-id type="github">ilanschnell/bitarray</remote-id>