summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/blessed')
-rw-r--r--dev-python/blessed/Manifest2
-rw-r--r--dev-python/blessed/blessed-1.20.0.ebuild (renamed from dev-python/blessed/blessed-1.17.11.ebuild)22
-rw-r--r--dev-python/blessed/metadata.xml7
3 files changed, 19 insertions, 12 deletions
diff --git a/dev-python/blessed/Manifest b/dev-python/blessed/Manifest
index 2a97dedf8be4..496a65259fce 100644
--- a/dev-python/blessed/Manifest
+++ b/dev-python/blessed/Manifest
@@ -1 +1 @@
-DIST blessed-1.17.11.tar.gz 6697714 BLAKE2B a181fac1675b0e06bca54346bd6eea4032fde739888d36a7ec51afbe899e5cc71ad924b6bae45777d9b56567da1771f89d451760ec2b62abaf10f6235c69a66f SHA512 51e627f27aea0082fc93a4b1d10043b1152ae8b625dbb6c73f75e993f8eebc41ed1d8e64667de28afbc4606d066a90dd4c69c79fbed7b5b928d126efd3fbac22
+DIST blessed-1.20.0.tar.gz 6655612 BLAKE2B 10523940ac2fe528487f2d1d68d9f38782ec260f1f42735940219d37d4b4dbaef2fd4ca63d753780123d54ae39ab04652d2c6ba8f3323c621a2206b0a706f6e0 SHA512 8567ff1c55f68ad99c6c524edbf8ee57813d23d885dcb372767debc76bc2d75642c2b0491e1ed05460f023c28403b5dabb13769dea101a1c6e3156c82e0d0355
diff --git a/dev-python/blessed/blessed-1.17.11.ebuild b/dev-python/blessed/blessed-1.20.0.ebuild
index 9904bbe07429..c1cc50599f54 100644
--- a/dev-python/blessed/blessed-1.17.11.ebuild
+++ b/dev-python/blessed/blessed-1.20.0.ebuild
@@ -1,19 +1,22 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( pypy3 python3_{6..9} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="Library for making terminal apps using colors, keyboard input and positioning"
-HOMEPAGE="https://github.com/jquast/blessed"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="
+ https://github.com/jquast/blessed/
+ https://pypi.org/project/blessed/
+"
SLOT="0"
LICENSE="MIT"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 arm64 ~riscv x86"
RDEPEND="
dev-python/six[${PYTHON_USEDEP}]
@@ -25,7 +28,7 @@ BDEPEND="
)
"
-distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
distutils_enable_tests pytest
python_prepare_all() {
@@ -44,6 +47,5 @@ python_test() {
# COLORTERM must not be truecolor
# See https://github.com/jquast/blessed/issues/162
# Ignore coverage options
- COLORTERM= pytest -vv --override-ini="addopts=" \
- || die "tests failed with ${EPYTHON}"
+ COLORTERM= epytest --override-ini="addopts="
}
diff --git a/dev-python/blessed/metadata.xml b/dev-python/blessed/metadata.xml
index 9bbec69c0c49..1f9611fd392e 100644
--- a/dev-python/blessed/metadata.xml
+++ b/dev-python/blessed/metadata.xml
@@ -1,10 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>sbraz@gentoo.org</email>
<name>Louis Sautier</name>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">blessed</remote-id>
<remote-id type="github">jquast/blessed</remote-id>