summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/blurb/blurb-1.0.8.ebuild')
-rw-r--r--dev-python/blurb/blurb-1.0.8.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/dev-python/blurb/blurb-1.0.8.ebuild b/dev-python/blurb/blurb-1.0.8.ebuild
index 7d7b1e6e16ca..2d91f40572a3 100644
--- a/dev-python/blurb/blurb-1.0.8.ebuild
+++ b/dev-python/blurb/blurb-1.0.8.ebuild
@@ -1,10 +1,9 @@
# Copyright 2018-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Tool to create and manage NEWS blurbs for CPython"
@@ -18,3 +17,14 @@ KEYWORDS="~amd64 ~x86"
PATCHES=(
"${FILESDIR}/blurb-setuptools.patch"
)
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # Tests expect to be run from github repo, in which code is inside dir
+ ln -s . blurb || die
+}
+
+python_test() {
+ "${EPYTHON}" -m blurb test || die "Tests failed with ${EPYTHON}"
+}