summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/blurb')
-rw-r--r--dev-python/blurb/Manifest1
-rw-r--r--dev-python/blurb/blurb-1.0.7.ebuild22
-rw-r--r--dev-python/blurb/files/blurb-setuptools.patch14
-rw-r--r--dev-python/blurb/metadata.xml23
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/blurb/Manifest b/dev-python/blurb/Manifest
new file mode 100644
index 000000000000..5a052f8be822
--- /dev/null
+++ b/dev-python/blurb/Manifest
@@ -0,0 +1 @@
+DIST blurb-1.0.7.tar.gz 21248 BLAKE2B 931a0db30447f5a41c956f15dac2bd967efd8a85d4837782e02af24edc31dec03d3fab27f22db1dafe334dcfc79b133cf99092fc28b59c190b1182d1f897e0bb SHA512 d84fdc0a7ecec1207a58a748f6d33343504d0b090166c91b05e9b3c2eb125fff890194539204386bdc7a1e0a595d2cb80d54d873045941491d26ca85cb55ac98
diff --git a/dev-python/blurb/blurb-1.0.7.ebuild b/dev-python/blurb/blurb-1.0.7.ebuild
new file mode 100644
index 000000000000..fe85e9a6768e
--- /dev/null
+++ b/dev-python/blurb/blurb-1.0.7.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2018 Sony Interactive Entertainment Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Tool to create and manage NEWS blurbs for CPython"
+HOMEPAGE="https://github.com/python/core-workflow/tree/master/blurb"
+SRC_URI="https://files.pythonhosted.org/packages/29/4f/268f9aa095cbcf53253c665fd0f5103f22dccf246fe317ab9c5c481b38f5/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/blurb-setuptools.patch"
+)
diff --git a/dev-python/blurb/files/blurb-setuptools.patch b/dev-python/blurb/files/blurb-setuptools.patch
new file mode 100644
index 000000000000..4845af98285a
--- /dev/null
+++ b/dev-python/blurb/files/blurb-setuptools.patch
@@ -0,0 +1,14 @@
+diff -u blurb-1.0.7.orig/setup.py blurb-1.0.7/setup.py
+--- blurb-1.0.7.orig/setup.py 1969-12-31 16:00:00.000000000 -0800
++++ blurb-1.0.7/setup.py 2018-11-05 14:58:55.148518033 -0800
+@@ -1,7 +1,7 @@
+ #!/usr/bin/env python
+ # setup.py generated by flit for tools that don't yet use PEP 517
+
+-from distutils.core import setup
++from setuptools import setup
+
+ entry_points = \
+ {'console_scripts': ['blurb = blurb:main']}
+Only in blurb-1.0.7: .setup.py.un~
+Common subdirectories: blurb-1.0.7.orig/tests and blurb-1.0.7/tests
diff --git a/dev-python/blurb/metadata.xml b/dev-python/blurb/metadata.xml
new file mode 100644
index 000000000000..a68165db0ed5
--- /dev/null
+++ b/dev-python/blurb/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <longdescription lang="en">
+ blurb is a tool designed to rid CPython core development of the scourge of
+ Misc/NEWS conflicts.
+
+ The core concept: split Misc/NEWS into many separate files that, when
+ concatenated back together in sorted order, reconstitute the original
+ Misc/NEWS file. After that, Misc/NEWS could be deleted from the CPython
+ repo and thereafter rendered on demand (e.g. when building a release).
+ When checking in a change to CPython, the checkin process will write
+ out a new file that sorts into the correct place, using a filename
+ unlikely to have a merge conflict.
+ </longdescription>
+</pkgmetadata>