summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/browser-cookie3/browser-cookie3-0.17.0.ebuild')
-rw-r--r--dev-python/browser-cookie3/browser-cookie3-0.17.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/browser-cookie3/browser-cookie3-0.17.0.ebuild b/dev-python/browser-cookie3/browser-cookie3-0.17.0.ebuild
new file mode 100644
index 000000000000..ecb4796279d5
--- /dev/null
+++ b/dev-python/browser-cookie3/browser-cookie3-0.17.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Loads cookies from your browser into a cookiejar object"
+HOMEPAGE="https://github.com/borisbabic/browser_cookie3/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/lz4[${PYTHON_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_prepare_all() {
+ # make cryptodome-friendly
+ sed -i -e 's:pycryptodomex:pycryptodome:' setup.py || die
+ sed -i -e 's:Cryptodome:Crypto:g' __init__.py || die
+
+ distutils-r1_python_prepare_all
+}