summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/btrfs/btrfs-14.1.ebuild')
-rw-r--r--dev-python/btrfs/btrfs-14.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/btrfs/btrfs-14.1.ebuild b/dev-python/btrfs/btrfs-14.1.ebuild
new file mode 100644
index 000000000000..31231aa8879c
--- /dev/null
+++ b/dev-python/btrfs/btrfs-14.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=python-btrfs-${PV}
+DESCRIPTION="Python module to inspect btrfs filesystems"
+HOMEPAGE="
+ https://github.com/knorrie/python-btrfs/
+ https://pypi.org/project/btrfs/
+"
+SRC_URI="
+ https://github.com/knorrie/python-btrfs/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="examples"
+
+python_install_all() {
+ if use examples; then
+ # skip symlink meant for development
+ rm examples/btrfs
+ dodoc -r examples
+ fi
+
+ distutils-r1_python_install_all
+}