summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cairocffi/cairocffi-0.8.0-r1.ebuild')
-rw-r--r--dev-python/cairocffi/cairocffi-0.8.0-r1.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/cairocffi/cairocffi-0.8.0-r1.ebuild b/dev-python/cairocffi/cairocffi-0.8.0-r1.ebuild
deleted file mode 100644
index ba91b5f72454..000000000000
--- a/dev-python/cairocffi/cairocffi-0.8.0-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit distutils-r1 virtualx
-
-MY_PN="${PN}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="CFFI-based drop-in replacement for Pycairo"
-HOMEPAGE="https://github.com/Kozea/cairocffi"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- $(python_gen_cond_dep '>=dev-python/cffi-1.1.0:=[${PYTHON_USEDEP}]' 'python*')
- >=dev-python/xcffib-0.3.2[${PYTHON_USEDEP}]
- x11-libs/cairo:0=[X,xcb(+)]
- x11-libs/gdk-pixbuf[jpeg]"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-PATCHES=( "${FILESDIR}"/${P}-tests.patch )
-
-S="${WORKDIR}/${MY_P}"
-
-python_compile_all() {
- use doc && esetup.py build_sphinx
-}
-
-python_test() {
- virtx py.test -v --pyargs cairocffi
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}