summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/carbon')
-rw-r--r--dev-python/carbon/Manifest1
-rw-r--r--dev-python/carbon/carbon-1.1.5.ebuild62
-rw-r--r--dev-python/carbon/files/carbon.confd5
-rw-r--r--dev-python/carbon/files/carbon.initd51
-rw-r--r--dev-python/carbon/files/carbon.initd253
-rw-r--r--dev-python/carbon/metadata.xml15
6 files changed, 0 insertions, 187 deletions
diff --git a/dev-python/carbon/Manifest b/dev-python/carbon/Manifest
deleted file mode 100644
index 02d3976e9e4e..000000000000
--- a/dev-python/carbon/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST carbon-1.1.5.tar.gz 72365 BLAKE2B 304e515fd3cae806e141d0a76983d13967885a7e57c310d86c0c83560aa306a573676fb0135fceccf14cc7ed42d8a9dcb7869ab0d6ac3b2fc00c2fb088011873 SHA512 1b3a0a0d4005e2ec8d5bca062b41f0e18329c1bc4d3a4b3eca5e8f7c94c20387281392eefceaca90294e51860eabecca242c487068433119f1f249f8659ed560
diff --git a/dev-python/carbon/carbon-1.1.5.ebuild b/dev-python/carbon/carbon-1.1.5.ebuild
deleted file mode 100644
index 920de7f1577a..000000000000
--- a/dev-python/carbon/carbon-1.1.5.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Backend data caching and persistence daemon for Graphite"
-HOMEPAGE="https://graphiteapp.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-KEYWORDS="~amd64 ~x86 ~x64-solaris"
-
-# whisper appears to have been missed from listing in install_requires in setup.py
-RDEPEND="
- dev-python/twisted[${PYTHON_USEDEP}]
- dev-python/cachetools[${PYTHON_USEDEP}]
- dev-python/txAMQP[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- =dev-python/whisper-${PV}*[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- # Do not install the configuration and data files. We install them
- # somewhere sensible by hand.
- sed -i -e '/data_files=install_files,/d' setup.py || die
- # We want FHS-style paths instead of /opt/graphite
- export GRAPHITE_NO_PREFIX=yes
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- insinto /etc/carbon
- doins conf/*
-
- keepdir /var/log/carbon /var/lib/carbon/{whisper,lists,rrd}
-
- newinitd "${FILESDIR}"/carbon.initd2 carbon-cache
- newinitd "${FILESDIR}"/carbon.initd2 carbon-relay
- newinitd "${FILESDIR}"/carbon.initd2 carbon-aggregator
-
- newconfd "${FILESDIR}"/carbon.confd carbon-cache
- newconfd "${FILESDIR}"/carbon.confd carbon-relay
- newconfd "${FILESDIR}"/carbon.confd carbon-aggregator
-}
-
-pkg_postinst() {
- einfo 'This ebuild installs carbon into FHS-style paths.'
- einfo 'You will probably have to set GRAPHITE_CONF_DIR to /etc/carbon'
- einfo 'and GRAPHITE_STORAGE_DIR to /var/lib/carbon to make use of this'
- einfo '(see /etc/carbon/carbon.conf.example).'
- einfo ' '
- einfo 'OpenRC init script supports multiple instances !'
- einfo 'Example to run an instance b of carbon-cache :'
- einfo ' ln -s /etc/init.d/carbon-cache /etc/init.d/carbon-cache.b'
- einfo ' cp /etc/conf.d/carbon-cache /etc/conf.d/carbon-cache.b'
-}
diff --git a/dev-python/carbon/files/carbon.confd b/dev-python/carbon/files/carbon.confd
deleted file mode 100644
index b1875e134678..000000000000
--- a/dev-python/carbon/files/carbon.confd
+++ /dev/null
@@ -1,5 +0,0 @@
-# Use the given config file
-CARBON_CONFIG="/etc/carbon/carbon.conf"
-
-# Add extra parameters
-CARBON_EXTRA_PARAMETERS=""
diff --git a/dev-python/carbon/files/carbon.initd b/dev-python/carbon/files/carbon.initd
deleted file mode 100644
index a33a70c60f93..000000000000
--- a/dev-python/carbon/files/carbon.initd
+++ /dev/null
@@ -1,51 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-export GRAPHITE_CONF_DIR=/etc/carbon
-export GRAPHITE_STORAGE_DIR=/var/lib/carbon
-
-INSTANCE=${SVCNAME/#*.}
-if [ "${INSTANCE}" == "${SVCNAME}" ]; then
- INSTANCE="a"
-fi
-
-PIDFILE="/var/run/${SVCNAME}.pid"
-PROGRAMNAME=${SVCNAME/.*}
-
-CARBON_CONFIG=${CARBON_CONFIG:-/etc/carbon/carbon.conf}
-
-depend() {
- use net
-}
-
-
-start_pre() {
- if [ ! -f ${CARBON_CONFIG} ] ; then
- eend "Missing ${CARBON_CONFIG}"
- fi
- case "${PROGRAMNAME}" in
- "carbon-relay" )
- [ -f /etc/carbon/relay-rules.conf ] || eend "Missing relay-rules.conf"
- ;;
- "carbon-aggregator" )
- [ -f /etc/carbon/aggregation-rules.conf ] || eend "Missing missing aggregation-rules.conf"
- ;;
- esac
-}
-
-start() {
- ebegin "Starting ${PROGRAMNAME} instance ${INSTANCE}"
- start-stop-daemon --start --exec /usr/bin/${PROGRAMNAME}.py \
- --pidfile ${PIDFILE} \
- -- --pidfile ${PIDFILE} --instance ${INSTANCE} \
- --logdir /var/log/carbon/ --config ${CARBON_CONFIG} start >/dev/null
- eend $? "Failed to start ${SVCNAME}"
-}
-
-stop() {
- ebegin "Stopping ${PROGRAMNAME} instance ${INSTANCE}"
- start-stop-daemon --stop \
- --pidfile ${PIDFILE}
- eend $? "Failed to stop ${SVCNAME}"
-}
diff --git a/dev-python/carbon/files/carbon.initd2 b/dev-python/carbon/files/carbon.initd2
deleted file mode 100644
index ff1509747ef1..000000000000
--- a/dev-python/carbon/files/carbon.initd2
+++ /dev/null
@@ -1,53 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-export GRAPHITE_CONF_DIR=/etc/carbon
-export GRAPHITE_STORAGE_DIR=/var/lib/carbon
-
-INSTANCE=${SVCNAME#*.}
-if [ "${INSTANCE}" = "${SVCNAME}" ]; then
- INSTANCE="a"
-fi
-
-PIDFILE="/var/run/${SVCNAME}.pid"
-PROGRAMNAME=${SVCNAME%%.*}
-
-CARBON_CONFIG=${CARBON_CONFIG:-/etc/carbon/carbon.conf}
-
-depend() {
- use net
-}
-
-
-start_pre() {
- if [ ! -f ${CARBON_CONFIG} ] ; then
- eend "Missing ${CARBON_CONFIG}"
- fi
- case "${PROGRAMNAME}" in
- "carbon-relay" )
- if `grep -q "^RELAY_METHOD = rules$" ${CARBON_CONFIG}`; then
- [ -f /etc/carbon/relay-rules.conf ] || eend "Missing relay-rules.conf"
- fi
- ;;
- "carbon-aggregator" )
- [ -f /etc/carbon/aggregation-rules.conf ] || eend "Missing missing aggregation-rules.conf"
- ;;
- esac
-}
-
-start() {
- ebegin "Starting ${PROGRAMNAME} instance ${INSTANCE}"
- start-stop-daemon --start --exec /usr/bin/${PROGRAMNAME}.py \
- --pidfile ${PIDFILE} \
- -- --pidfile ${PIDFILE} --instance ${INSTANCE} \
- --logdir /var/log/carbon/ --config ${CARBON_CONFIG} start >/dev/null
- eend $? "Failed to start ${SVCNAME}"
-}
-
-stop() {
- ebegin "Stopping ${PROGRAMNAME} instance ${INSTANCE}"
- start-stop-daemon --stop \
- --pidfile ${PIDFILE}
- eend $? "Failed to stop ${SVCNAME}"
-}
diff --git a/dev-python/carbon/metadata.xml b/dev-python/carbon/metadata.xml
deleted file mode 100644
index 652e85d0ce90..000000000000
--- a/dev-python/carbon/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>patrick@gentoo.org</email>
- <name>Patrick Lauer</name>
- </maintainer>
- <maintainer type="person">
- <email>grobian@gentoo.org</email>
- <name>Fabian Groffen</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">carbon</remote-id>
- </upstream>
-</pkgmetadata>