summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/casttube/casttube-0.2.1.ebuild')
-rw-r--r--dev-python/casttube/casttube-0.2.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/casttube/casttube-0.2.1.ebuild b/dev-python/casttube/casttube-0.2.1.ebuild
new file mode 100644
index 000000000000..db1f1d648330
--- /dev/null
+++ b/dev-python/casttube/casttube-0.2.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="casttube provides a way to interact with the Youtube Chromecast api."
+HOMEPAGE="https://github.com/ur1katz/casttube"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -e '/data_files/d' -i setup.py || die
+ distutils-r1_src_prepare
+}