summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cbor2/cbor2-5.4.2_p1.ebuild')
-rw-r--r--dev-python/cbor2/cbor2-5.4.2_p1.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/cbor2/cbor2-5.4.2_p1.ebuild b/dev-python/cbor2/cbor2-5.4.2_p1.ebuild
deleted file mode 100644
index 6c289191ab71..000000000000
--- a/dev-python/cbor2/cbor2-5.4.2_p1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-MY_P=${P/_p/.post}
-DESCRIPTION="Pure Python CBOR (de)serializer with extensive tag support"
-HOMEPAGE="
- https://github.com/agronholm/cbor2/
- https://pypi.org/project/cbor2/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
-
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # remove pytest-cov dep
- sed -e "s/pytest-cov//" \
- -e "s/--cov //" \
- -i setup.cfg || die
-
- distutils-r1_python_prepare_all
-}