summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cfn-python-lint')
-rw-r--r--dev-python/cfn-python-lint/Manifest3
-rw-r--r--dev-python/cfn-python-lint/cfn-python-lint-0.50.0.ebuild57
-rw-r--r--dev-python/cfn-python-lint/cfn-python-lint-0.51.0.ebuild57
-rw-r--r--dev-python/cfn-python-lint/cfn-python-lint-0.52.0.ebuild57
-rw-r--r--dev-python/cfn-python-lint/files/cfn-python-lint-0.30.1-tests.patch20
-rw-r--r--dev-python/cfn-python-lint/metadata.xml18
6 files changed, 0 insertions, 212 deletions
diff --git a/dev-python/cfn-python-lint/Manifest b/dev-python/cfn-python-lint/Manifest
deleted file mode 100644
index e4d5479e3662..000000000000
--- a/dev-python/cfn-python-lint/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST cfn-lint-0.50.0.tar.gz 7061105 BLAKE2B bba39823b729b0a53dcc97341b6408654190bceb86acd7de0e2ee1a4ae34234ca6ddc3a4d374c38115632faa0fbbb51fbf07cf717853dd917a262ef5c1116ac9 SHA512 9dc5c00946a9bb142771a4b63571043056b1f522348f11256d7d3181e750c251cfab805a66df884b496fd7639442da0e72f65c0a43cc2ce2ed35f214031c7b1a
-DIST cfn-lint-0.51.0.tar.gz 7125333 BLAKE2B 5f18c03cba52e8f38eb4998ce3640564b6346cd788bc7ca4eebbeebf709fddb130de3fd0c99f5e1585aa07fb965f97ec05d48154bb6788f961c31301058d9ac7 SHA512 6b0eada5204da1c4efbf1a548b74065008bf55142b666aefbc5c1e9311eaaef96e83fd427157be4d3dec98d2e5377ed7f21266af0662e565fdf2aeb6883bb1e4
-DIST cfn-lint-0.52.0.tar.gz 7221391 BLAKE2B 20422bb191e9537ba6950db8c40894ab07655389a0a81eff3489f5bcd626bd81c6f9749f885b8be4f4939f16abe62fbbde7c741e770e6265c28bd59740144558 SHA512 81274b973ede2e60ef113d5ec4e2052dc11ed0a85b79079dd1b40e8afae3738cbd963b2e703f5016e216b2844df8711a34ff024e5dc4b1b12e774176bbe88489
diff --git a/dev-python/cfn-python-lint/cfn-python-lint-0.50.0.ebuild b/dev-python/cfn-python-lint/cfn-python-lint-0.50.0.ebuild
deleted file mode 100644
index 348163842a48..000000000000
--- a/dev-python/cfn-python-lint/cfn-python-lint-0.50.0.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
-inherit distutils-r1
-
-# TODO: pkgmove to cfn-lint
-MY_P=${P/-python}
-DESCRIPTION="CloudFormation Linter"
-HOMEPAGE="https://pypi.org/project/cfn-lint/ https://github.com/aws-cloudformation/cfn-lint/"
-SRC_URI="
- https://github.com/aws-cloudformation/cfn-lint/archive/v${PV}.tar.gz
- -> ${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-
-RDEPEND="
- >=dev-python/aws-sam-translator-1.35.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/importlib_resources[${PYTHON_USEDEP}]
- ' python3_6)
- dev-python/jsonpatch[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
- dev-python/junit-xml[${PYTHON_USEDEP}]
- dev-python/networkx[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
- >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.11[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests --install unittest
-
-PATCHES=(
- "${FILESDIR}/cfn-python-lint-0.30.1-tests.patch"
-)
-
-src_prepare() {
- # unpin the deps
- sed -e 's:~=[0-9.]*::' -i setup.py || die
- # requires git checkout
- sed -e 's:test_update_docs:_&:' \
- -i test/unit/module/maintenance/test_update_documentation.py || die
- # requires Internet
- sed -e 's:test_update_resource_specs_python:_&:' \
- -i test/unit/module/maintenance/test_update_resource_specs.py || die
- distutils-r1_src_prepare
-}
diff --git a/dev-python/cfn-python-lint/cfn-python-lint-0.51.0.ebuild b/dev-python/cfn-python-lint/cfn-python-lint-0.51.0.ebuild
deleted file mode 100644
index 2ca06957a777..000000000000
--- a/dev-python/cfn-python-lint/cfn-python-lint-0.51.0.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
-inherit distutils-r1
-
-# TODO: pkgmove to cfn-lint
-MY_P=${P/-python}
-DESCRIPTION="CloudFormation Linter"
-HOMEPAGE="https://pypi.org/project/cfn-lint/ https://github.com/aws-cloudformation/cfn-lint/"
-SRC_URI="
- https://github.com/aws-cloudformation/cfn-lint/archive/v${PV}.tar.gz
- -> ${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-
-RDEPEND="
- >=dev-python/aws-sam-translator-1.35.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/importlib_resources[${PYTHON_USEDEP}]
- ' python3_6)
- dev-python/jsonpatch[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
- dev-python/junit-xml[${PYTHON_USEDEP}]
- dev-python/networkx[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
- >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.11[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests --install unittest
-
-PATCHES=(
- "${FILESDIR}/cfn-python-lint-0.30.1-tests.patch"
-)
-
-src_prepare() {
- # unpin the deps
- sed -e 's:~=[0-9.]*::' -i setup.py || die
- # requires git checkout
- sed -e 's:test_update_docs:_&:' \
- -i test/unit/module/maintenance/test_update_documentation.py || die
- # requires Internet
- sed -e 's:test_update_resource_specs_python:_&:' \
- -i test/unit/module/maintenance/test_update_resource_specs.py || die
- distutils-r1_src_prepare
-}
diff --git a/dev-python/cfn-python-lint/cfn-python-lint-0.52.0.ebuild b/dev-python/cfn-python-lint/cfn-python-lint-0.52.0.ebuild
deleted file mode 100644
index 928f06df62fd..000000000000
--- a/dev-python/cfn-python-lint/cfn-python-lint-0.52.0.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-inherit distutils-r1
-
-# TODO: pkgmove to cfn-lint
-MY_P=${P/-python}
-DESCRIPTION="CloudFormation Linter"
-HOMEPAGE="https://pypi.org/project/cfn-lint/ https://github.com/aws-cloudformation/cfn-lint/"
-SRC_URI="
- https://github.com/aws-cloudformation/cfn-lint/archive/v${PV}.tar.gz
- -> ${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-
-RDEPEND="
- >=dev-python/aws-sam-translator-1.35.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/importlib_resources[${PYTHON_USEDEP}]
- ' python3_6)
- dev-python/jsonpatch[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
- dev-python/junit-xml[${PYTHON_USEDEP}]
- dev-python/networkx[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
- >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.11[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests --install unittest
-
-PATCHES=(
- "${FILESDIR}/cfn-python-lint-0.30.1-tests.patch"
-)
-
-src_prepare() {
- # unpin the deps
- sed -e 's:~=[0-9.]*::' -i setup.py || die
- # requires git checkout
- sed -e 's:test_update_docs:_&:' \
- -i test/unit/module/maintenance/test_update_documentation.py || die
- # requires Internet
- sed -e 's:test_update_resource_specs_python:_&:' \
- -i test/unit/module/maintenance/test_update_resource_specs.py || die
- distutils-r1_src_prepare
-}
diff --git a/dev-python/cfn-python-lint/files/cfn-python-lint-0.30.1-tests.patch b/dev-python/cfn-python-lint/files/cfn-python-lint-0.30.1-tests.patch
deleted file mode 100644
index 6c81aef9a7a8..000000000000
--- a/dev-python/cfn-python-lint/files/cfn-python-lint-0.30.1-tests.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff --git a/test/unit/module/test_template.py b/test/unit/module/test_template.py
-index 813040c9..a7554a31 100644
---- a/test/unit/module/test_template.py
-+++ b/test/unit/module/test_template.py
-@@ -4,6 +4,7 @@ SPDX-License-Identifier: MIT-0
- """
- import json
- import os
-+import unittest
- from test.testlib.testcase import BaseTestCase
- import cfnlint.helpers
- from cfnlint import Template # pylint: disable=E0401
-@@ -34,6 +35,7 @@ class TestTemplate(BaseTestCase):
- 'pIops'
- ]
-
-+ @unittest.skip("tests seems to be broken")
- def test_build_graph(self):
- self.template.build_graph()
-
diff --git a/dev-python/cfn-python-lint/metadata.xml b/dev-python/cfn-python-lint/metadata.xml
deleted file mode 100644
index 270b9eef5dd1..000000000000
--- a/dev-python/cfn-python-lint/metadata.xml
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>zmedico@gentoo.org</email>
- <name>Zac Medico</name>
- </maintainer>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <stabilize-allarches/>
- <upstream>
- <remote-id type="github">aws-cloudformation/cfn-python-lint</remote-id>
- <remote-id type="pypi">cfn-lint</remote-id>
- <bugs-to>https://github.com/aws-cloudformation/cfn-python-lint/issues</bugs-to>
- </upstream>
-</pkgmetadata>