summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cherrypy/cherrypy-18.5.0.ebuild')
-rw-r--r--dev-python/cherrypy/cherrypy-18.5.0.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-python/cherrypy/cherrypy-18.5.0.ebuild b/dev-python/cherrypy/cherrypy-18.5.0.ebuild
index 7d90d9a6bf26..23a04475d93c 100644
--- a/dev-python/cherrypy/cherrypy-18.5.0.ebuild
+++ b/dev-python/cherrypy/cherrypy-18.5.0.ebuild
@@ -25,24 +25,20 @@ RDEPEND=">=dev-python/cheroot-8.2.1[${PYTHON_USEDEP}]
dev-python/zc-lockfile[${PYTHON_USEDEP}]
dev-python/jaraco-collections[${PYTHON_USEDEP}]
ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )"
-BDEPEND="${RDEPEND}
+BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/setuptools_scm[${PYTHON_USEDEP}]
test? (
+ ${RDEPEND}
dev-python/routes[${PYTHON_USEDEP}]
dev-python/simplejson[${PYTHON_USEDEP}]
dev-python/objgraph[${PYTHON_USEDEP}]
- dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
dev-python/path-py[${PYTHON_USEDEP}]
dev-python/requests-toolbelt[${PYTHON_USEDEP}]
dev-python/pytest-services[${PYTHON_USEDEP}]
)
"
-PATCHES=(
- "${FILESDIR}/cherrypy-18.5.0-tests.patch"
-)
-
distutils_enable_tests pytest
python_prepare_all() {
@@ -50,6 +46,10 @@ python_prepare_all() {
sed -e 's|@pytest.mark.xfail(py27_on_windows|@pytest.mark.xfail(sys.version_info < (3,)|' \
-i cherrypy/test/test_static.py || die
+ # fragile, fails with newer versions of CPython
+ sed -e 's:testCombinedTools:_&:' \
+ -i cherrypy/test/test_tools.py || die
+
sed -r -e '/(pytest-sugar|pytest-cov)/ d' \
-i setup.py || die