summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cli_helpers/cli_helpers-1.2.1.ebuild')
-rw-r--r--dev-python/cli_helpers/cli_helpers-1.2.1.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/cli_helpers/cli_helpers-1.2.1.ebuild b/dev-python/cli_helpers/cli_helpers-1.2.1.ebuild
deleted file mode 100644
index 0de3c188e8b8..000000000000
--- a/dev-python/cli_helpers/cli_helpers-1.2.1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-inherit distutils-r1
-
-DESCRIPTION="Python helpers for common CLI tasks"
-HOMEPAGE="https://cli-helpers.rtfd.io/"
-SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
- >=dev-python/tabulate-0.8.0[${PYTHON_USEDEP}]
- >=dev-python/terminaltables-3.0.0[${PYTHON_USEDEP}]
- dev-python/wcwidth[${PYTHON_USEDEP}]
-"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- >=dev-python/mock-2[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}