summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/click-help-colors')
-rw-r--r--dev-python/click-help-colors/Manifest3
-rw-r--r--dev-python/click-help-colors/click-help-colors-0.9.1.ebuild27
-rw-r--r--dev-python/click-help-colors/click-help-colors-0.9.4.ebuild40
-rw-r--r--dev-python/click-help-colors/click-help-colors-0.9.ebuild26
-rw-r--r--dev-python/click-help-colors/files/click-help-colors-0.9.4-no-color.patch14
-rw-r--r--dev-python/click-help-colors/metadata.xml6
6 files changed, 60 insertions, 56 deletions
diff --git a/dev-python/click-help-colors/Manifest b/dev-python/click-help-colors/Manifest
index 2291f521566a..aaa51cbdf8d5 100644
--- a/dev-python/click-help-colors/Manifest
+++ b/dev-python/click-help-colors/Manifest
@@ -1,2 +1 @@
-DIST click-help-colors-0.9.1.tar.gz 101042 BLAKE2B 0f40d6d15f8e0a4647212f57e071c49b66bcd2b3d7ef582bd7d8a14135e50028f3ceb07987b5b74a868d998c12886a711f40e1d85b541566c63dca39e43a907d SHA512 ac4ce56ab249f7b98f670a6624700109f20a7c666e006b891d5c9fd4977512a0c94d82f6b43915952179abc946899f85fa1d358cd3d59508ef341ba22d8fc745
-DIST click-help-colors-0.9.tar.gz 100701 BLAKE2B 838507658aec9cea962d1f373bd771871837d1fe274c70fe4555efbd4e1825203d8728457c5836a482add26e86d4eed83b962811602864d43bf8174f49bd89cd SHA512 02cca02a5cec6b3b23fdeee4aef921cac1cf83d85bea8eb04dd100955dc27b2e4d098bad2f49694c0aa6548135fb979a1fd054525dcec27077f461a034d62a87
+DIST click-help-colors-0.9.4.gh.tar.gz 131221 BLAKE2B cb6e5818eddf8ac757206b537053368be672382133bd6a1de65653b671c8780e991b437a31313740303b0e9d6d84eccb04b84577149311c3a27ad9fdaae4c5a4 SHA512 9dd7cc972834e4711cd9f3e957ab50aaa9e7c3e983a98d2d35603a548c85c9c3d3104f567cd13250eb621b67d138b7b94771216dc8323a281fe4fee51d7b752e
diff --git a/dev-python/click-help-colors/click-help-colors-0.9.1.ebuild b/dev-python/click-help-colors/click-help-colors-0.9.1.ebuild
deleted file mode 100644
index 251b5c3328a4..000000000000
--- a/dev-python/click-help-colors/click-help-colors-0.9.1.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Colorization of help messages in Click"
-HOMEPAGE="https://github.com/click-contrib/click-help-colors"
-SRC_URI="
- https://github.com/click-contrib/${PN}/archive/${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="examples"
-
-RDEPEND="dev-python/click[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}
diff --git a/dev-python/click-help-colors/click-help-colors-0.9.4.ebuild b/dev-python/click-help-colors/click-help-colors-0.9.4.ebuild
new file mode 100644
index 000000000000..d187df21e384
--- /dev/null
+++ b/dev-python/click-help-colors/click-help-colors-0.9.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Colorization of help messages in Click"
+HOMEPAGE="
+ https://github.com/click-contrib/click-help-colors/
+ https://pypi.org/project/click-help-colors/
+"
+SRC_URI="
+ https://github.com/click-contrib/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~riscv"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/click-contrib/click-help-colors/pull/25
+ # https://github.com/click-contrib/click-help-colors/pull/26
+ "${FILESDIR}/${P}-no-color.patch"
+)
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/click-help-colors/click-help-colors-0.9.ebuild b/dev-python/click-help-colors/click-help-colors-0.9.ebuild
deleted file mode 100644
index 0f16c35209b3..000000000000
--- a/dev-python/click-help-colors/click-help-colors-0.9.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Colorization of help messages in Click"
-HOMEPAGE="https://github.com/click-contrib/click-help-colors"
-SRC_URI="https://github.com/click-contrib/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="examples"
-
-RDEPEND="<dev-python/click-9[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}
diff --git a/dev-python/click-help-colors/files/click-help-colors-0.9.4-no-color.patch b/dev-python/click-help-colors/files/click-help-colors-0.9.4-no-color.patch
new file mode 100644
index 000000000000..bc8ca134fb67
--- /dev/null
+++ b/dev-python/click-help-colors/files/click-help-colors-0.9.4-no-color.patch
@@ -0,0 +1,14 @@
+diff --git a/tests/conftest.py b/tests/conftest.py
+index 10482b8..25827a0 100644
+--- a/tests/conftest.py
++++ b/tests/conftest.py
+@@ -7,3 +7,9 @@ from click.testing import CliRunner
+ @pytest.fixture
+ def runner():
+ return CliRunner()
++
++
++@pytest.fixture(autouse=True)
++def clean_env(monkeypatch):
++ monkeypatch.delenv("FORCE_COLOR", raising=False)
++ monkeypatch.delenv("NO_COLOR", raising=False)
diff --git a/dev-python/click-help-colors/metadata.xml b/dev-python/click-help-colors/metadata.xml
index 4f878dd813d2..fe0a11d5b717 100644
--- a/dev-python/click-help-colors/metadata.xml
+++ b/dev-python/click-help-colors/metadata.xml
@@ -1,10 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>marecki@gentoo.org</email>
<name>Marek Szuba</name>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
<stabilize-allarches/>
<upstream>
<remote-id type="github">click-contrib/click-help-colors</remote-id>