summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/click')
-rw-r--r--dev-python/click/Manifest3
-rw-r--r--dev-python/click/click-7.1.2-r1.ebuild27
-rw-r--r--dev-python/click/click-8.0.1.ebuild34
-rw-r--r--dev-python/click/click-8.1.7.ebuild38
4 files changed, 39 insertions, 63 deletions
diff --git a/dev-python/click/Manifest b/dev-python/click/Manifest
index 2b8c6583eb94..25eb4215e1df 100644
--- a/dev-python/click/Manifest
+++ b/dev-python/click/Manifest
@@ -1,2 +1 @@
-DIST click-7.1.2.tar.gz 295757 BLAKE2B aea76d5378cfa49fe58a83132737d609d48b3d3a71ec65c0a8a144c7a0e244b5bdf0196ffe2150889b82edda20c3f1faa3c84a227fc9ef459a5a9646cff86129 SHA512 d0caf2fb0a258774a18a7b8f83bdfa73abeb70196a70b45a6cc35befaeb862d068d2f2cce4e27201ab2e3adcd02e7e2f099d6c37c497a507010eefa10ad16eba
-DIST click-8.0.1.tar.gz 330890 BLAKE2B ae0a29bf1848e92c21ade72fb8ce08991c9edf6d5afb6d70a0dd85cdbfacffeac69a675dc0842566ae23ed8c666deac97879ad4611e8294ee1c6896ea2ddca8a SHA512 d93ec1d070dfa306733ee79893c64de9afcb0c7bf03d3f543dd697ef195f3a750828f77842a22886960a938740b92f0122962076ea52b911b87f7f75941a9032
+DIST click-8.1.7.gh.tar.gz 341625 BLAKE2B 11acc52c1138945e2588019811c88c4edf492fe7de44a17e9e5b60f0ca503c22f877ff42b3384b95cf207995d8cd7c8c3c90b47be2bf2b3f4efc0d03ab883405 SHA512 a1cb115b90193d78f94ec2a6af563b089820517e6e0e4b71ea3d6c68304444d16db3597358c62e1757d9d05449996b7168a220eecde6ab4991367fdb6e74096f
diff --git a/dev-python/click/click-7.1.2-r1.ebuild b/dev-python/click/click-7.1.2-r1.ebuild
deleted file mode 100644
index edce25518b62..000000000000
--- a/dev-python/click/click-7.1.2-r1.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A Python package for creating beautiful command line interfaces"
-SRC_URI="https://github.com/pallets/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-HOMEPAGE="https://palletsprojects.com/p/click/ https://pypi.org/project/click/"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-IUSE="examples"
-
-distutils_enable_sphinx docs \
- '>=dev-python/docutils-0.14' \
- dev-python/pallets-sphinx-themes
-distutils_enable_tests pytest
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}
diff --git a/dev-python/click/click-8.0.1.ebuild b/dev-python/click/click-8.0.1.ebuild
deleted file mode 100644
index b71014ee0cbb..000000000000
--- a/dev-python/click/click-8.0.1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A Python package for creating beautiful command line interfaces"
-SRC_URI="https://github.com/pallets/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-HOMEPAGE="https://palletsprojects.com/p/click/ https://pypi.org/project/click/"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-IUSE="examples"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
- ' python3_7 pypy3)"
-
-distutils_enable_sphinx docs \
- '>=dev-python/docutils-0.14' \
- dev-python/pallets-sphinx-themes \
- dev-python/sphinxcontrib-log_cabinet \
- dev-python/sphinx-issues
-distutils_enable_tests pytest
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}
diff --git a/dev-python/click/click-8.1.7.ebuild b/dev-python/click/click-8.1.7.ebuild
new file mode 100644
index 000000000000..bc39e3ec0a10
--- /dev/null
+++ b/dev-python/click/click-8.1.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+HOMEPAGE="
+ https://palletsprojects.com/p/click/
+ https://github.com/pallets/click/
+ https://pypi.org/project/click/
+"
+SRC_URI="
+ https://github.com/pallets/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
+IUSE="examples"
+
+distutils_enable_sphinx docs \
+ '>=dev-python/docutils-0.14' \
+ dev-python/pallets-sphinx-themes \
+ dev-python/sphinxcontrib-log-cabinet \
+ dev-python/sphinx-issues \
+ dev-python/sphinx-tabs
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}