summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cliff')
-rw-r--r--dev-python/cliff/Manifest3
-rw-r--r--dev-python/cliff/cliff-4.6.0.ebuild (renamed from dev-python/cliff/cliff-4.2.0.ebuild)10
-rw-r--r--dev-python/cliff/cliff-4.7.0.ebuild40
-rw-r--r--dev-python/cliff/metadata.xml1
4 files changed, 46 insertions, 8 deletions
diff --git a/dev-python/cliff/Manifest b/dev-python/cliff/Manifest
index c628a42d7fc8..bfe0f1eeca57 100644
--- a/dev-python/cliff/Manifest
+++ b/dev-python/cliff/Manifest
@@ -1 +1,2 @@
-DIST cliff-4.2.0.tar.gz 83168 BLAKE2B ac2d288ac3728f4266d61edb9b6aedc897e9020d3f8a74ebba4721530942a27335564c2a95406a4d6b5374df49e38bc0aa303d3aff12f83c91e48c59f13aa45f SHA512 6f0c31b49603be5289e6d4c9b2572862e977264df21dc14d976289c627909102d672ee8ffa5b6cd79b3a349158ff8f36444a2d2061e18eeb7121ce79b2d5719b
+DIST cliff-4.6.0.tar.gz 83765 BLAKE2B a71ec00ac4525b960da4b40135477a3ed3fab8651c12b69af1a48ef19ae6e2eec37c8ab8f83ab23e0a948b002a7bfb152b677fd0ec313deb5e70ee5cb37fdd46 SHA512 59e887eddbdf695927e9ece46749f3f62557fd20bb24d7ff109f174a4ae4886cb3b44994903522c1d31c83b9f7f101f16604f6ffc4167ed6405e49a09f236dd0
+DIST cliff-4.7.0.tar.gz 84250 BLAKE2B e49cb9b5e05ab37885df47b80489e41eaf7662cf39ce61bdcb545a6ef5496b786c94c60c2164af15ae9536af7a9841e723fa62091300b28a49beed8945941dc0 SHA512 f1e6a28fbedb911efae02a3827f019411b99afdc316fcb07b115ca2157dcd23bbcce72d2d63b9850bb5b1cb21a4787575528a26d178943f7aba2a125ed9b55e5
diff --git a/dev-python/cliff/cliff-4.2.0.ebuild b/dev-python/cliff/cliff-4.6.0.ebuild
index 05639f5c552a..c8436db6e065 100644
--- a/dev-python/cliff/cliff-4.2.0.ebuild
+++ b/dev-python/cliff/cliff-4.6.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
@@ -24,15 +24,13 @@ RDEPEND="
>=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
dev-python/prettytable[${PYTHON_USEDEP}]
>=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
- >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
>=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/importlib_metadata-4.11.1[${PYTHON_USEDEP}]
- ' 3.8 3.9)
+ >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
"
BDEPEND="
>dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
>=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
>=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
diff --git a/dev-python/cliff/cliff-4.7.0.ebuild b/dev-python/cliff/cliff-4.7.0.ebuild
new file mode 100644
index 000000000000..087b9699e509
--- /dev/null
+++ b/dev-python/cliff/cliff-4.7.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="
+ https://opendev.org/openstack/cliff/
+ https://github.com/openstack/cliff/
+ https://pypi.org/project/cliff/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/autopage-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-5.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
diff --git a/dev-python/cliff/metadata.xml b/dev-python/cliff/metadata.xml
index 5742627c8671..d77f98508ed6 100644
--- a/dev-python/cliff/metadata.xml
+++ b/dev-python/cliff/metadata.xml
@@ -17,7 +17,6 @@
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">cliff</remote-id>
- <remote-id type="github">dreamhost/cliff</remote-id>
<remote-id type="github">openstack/cliff</remote-id>
</upstream>
</pkgmetadata>