summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cliff')
-rw-r--r--dev-python/cliff/Manifest4
-rw-r--r--dev-python/cliff/cliff-3.4.0.ebuild41
-rw-r--r--dev-python/cliff/cliff-3.5.0.ebuild41
-rw-r--r--dev-python/cliff/cliff-4.6.0.ebuild40
-rw-r--r--dev-python/cliff/cliff-4.7.0.ebuild40
-rw-r--r--dev-python/cliff/metadata.xml38
6 files changed, 101 insertions, 103 deletions
diff --git a/dev-python/cliff/Manifest b/dev-python/cliff/Manifest
index 6a03bc74cc1f..bfe0f1eeca57 100644
--- a/dev-python/cliff/Manifest
+++ b/dev-python/cliff/Manifest
@@ -1,2 +1,2 @@
-DIST cliff-3.4.0.tar.gz 78990 BLAKE2B d7d8209e2fe24614cde6d3e113eb0dbbba981addef045fe318143e71f9a240188c0fb74e831d868b31b6dafb4289f7beabfbb5fe1dade1df196f670c53a55549 SHA512 d625588f4eed0aeee549b4a21e604f1cb886b8c10a12df7c546a5292223ec5bf9067352b4d326d5710673dab56eec47e2fb46c9c5d5df6e9fbf026d030bcde1c
-DIST cliff-3.5.0.tar.gz 82997 BLAKE2B f169770a0a956e6091e56eccda8d10906bee09bdb03b474f3b17837b3eda858f3afd21beae1d6945bcdabfa89fc1555d13d70ddd0454a10fe05bfb63c8de75e7 SHA512 215f22e5dd2c4c17bd0f19866189b6b247377a7d5bddeb4a07b7536af7545bd0440b5fb0a98474fc018e3b12f6695f60028c012f3e7eeb6498b20f2923939d08
+DIST cliff-4.6.0.tar.gz 83765 BLAKE2B a71ec00ac4525b960da4b40135477a3ed3fab8651c12b69af1a48ef19ae6e2eec37c8ab8f83ab23e0a948b002a7bfb152b677fd0ec313deb5e70ee5cb37fdd46 SHA512 59e887eddbdf695927e9ece46749f3f62557fd20bb24d7ff109f174a4ae4886cb3b44994903522c1d31c83b9f7f101f16604f6ffc4167ed6405e49a09f236dd0
+DIST cliff-4.7.0.tar.gz 84250 BLAKE2B e49cb9b5e05ab37885df47b80489e41eaf7662cf39ce61bdcb545a6ef5496b786c94c60c2164af15ae9536af7a9841e723fa62091300b28a49beed8945941dc0 SHA512 f1e6a28fbedb911efae02a3827f019411b99afdc316fcb07b115ca2157dcd23bbcce72d2d63b9850bb5b1cb21a4787575528a26d178943f7aba2a125ed9b55e5
diff --git a/dev-python/cliff/cliff-3.4.0.ebuild b/dev-python/cliff/cliff-3.4.0.ebuild
deleted file mode 100644
index 8a9b0147ca33..000000000000
--- a/dev-python/cliff/cliff-3.4.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-# TODO: revert to rdepend once this is merged
-# https://github.com/openstack/cliff/pull/3
-DISTUTILS_USE_SETUPTOOLS=manual
-
-inherit distutils-r1
-
-DESCRIPTION="Command Line Interface Formulation Framework"
-HOMEPAGE="https://github.com/openstack/cliff"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm64 hppa ~ia64 ~mips ~ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
- <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
- >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests unittest
diff --git a/dev-python/cliff/cliff-3.5.0.ebuild b/dev-python/cliff/cliff-3.5.0.ebuild
deleted file mode 100644
index 5e6f9629a908..000000000000
--- a/dev-python/cliff/cliff-3.5.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-# TODO: revert to rdepend once this is merged
-# https://github.com/openstack/cliff/pull/3
-DISTUTILS_USE_SETUPTOOLS=manual
-
-inherit distutils-r1
-
-DESCRIPTION="Command Line Interface Formulation Framework"
-HOMEPAGE="https://github.com/openstack/cliff"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
- <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
- >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests unittest
diff --git a/dev-python/cliff/cliff-4.6.0.ebuild b/dev-python/cliff/cliff-4.6.0.ebuild
new file mode 100644
index 000000000000..c8436db6e065
--- /dev/null
+++ b/dev-python/cliff/cliff-4.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="
+ https://opendev.org/openstack/cliff/
+ https://github.com/openstack/cliff/
+ https://pypi.org/project/cliff/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND="
+ >=dev-python/autopage-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
diff --git a/dev-python/cliff/cliff-4.7.0.ebuild b/dev-python/cliff/cliff-4.7.0.ebuild
new file mode 100644
index 000000000000..087b9699e509
--- /dev/null
+++ b/dev-python/cliff/cliff-4.7.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="
+ https://opendev.org/openstack/cliff/
+ https://github.com/openstack/cliff/
+ https://pypi.org/project/cliff/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/autopage-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-5.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
diff --git a/dev-python/cliff/metadata.xml b/dev-python/cliff/metadata.xml
index 75edbe394a4f..d77f98508ed6 100644
--- a/dev-python/cliff/metadata.xml
+++ b/dev-python/cliff/metadata.xml
@@ -1,22 +1,22 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>prometheanfire@gentoo.org</email>
- <name>Matthew Thode</name>
- </maintainer>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <longdescription lang="en">
- Cliff is a framework for building command line programs.
- It uses setuptools entry points to provide subcommands,
- output formatters, and other extensions.
- </longdescription>
- <stabilize-allarches/>
- <upstream>
- <remote-id type="pypi">cliff</remote-id>
- <remote-id type="github">dreamhost/cliff</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Cliff is a framework for building command line programs.
+ It uses setuptools entry points to provide subcommands,
+ output formatters, and other extensions.
+ </longdescription>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">cliff</remote-id>
+ <remote-id type="github">openstack/cliff</remote-id>
+ </upstream>
</pkgmetadata>