summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cliff')
-rw-r--r--dev-python/cliff/Manifest3
-rw-r--r--dev-python/cliff/cliff-3.8.0.ebuild40
-rw-r--r--dev-python/cliff/cliff-4.6.0.ebuild (renamed from dev-python/cliff/cliff-3.9.0.ebuild)27
-rw-r--r--dev-python/cliff/metadata.xml1
4 files changed, 14 insertions, 57 deletions
diff --git a/dev-python/cliff/Manifest b/dev-python/cliff/Manifest
index 10a5a849da0c..a884de01fe6c 100644
--- a/dev-python/cliff/Manifest
+++ b/dev-python/cliff/Manifest
@@ -1,2 +1 @@
-DIST cliff-3.8.0.tar.gz 81862 BLAKE2B 3a8219f822fdf14e1de56204b0f536a92d27be5a99fb628f3aed5b569a1e703d4711bdded28fa42c0692316454847ba3338baac8efae873540652e46d155227a SHA512 002e3ddfb254c5369582cc28572856a8b4ad05d598a7f8aa690add69f49cabb12ef2ef17b6c1553792aaee785b7c1703b05dd9d4889271cd5eba5629fad3d09b
-DIST cliff-3.9.0.tar.gz 82687 BLAKE2B d49840831e55a205e809abeb54a6c9d45e807a622dc9b02a104311b8a5ddda43415b504f7fd62075cc4cdf89a1b61605ecf32590fbca3d720c07da83d58890a2 SHA512 04b33e14c3b29a02dc04855044184f934919ff92dbc09003f620083e5815597f8dee7201fa33019dd58a3e701d4c3f9966be1f4d23e019a881fee9a9bc1f0dbd
+DIST cliff-4.6.0.tar.gz 83765 BLAKE2B a71ec00ac4525b960da4b40135477a3ed3fab8651c12b69af1a48ef19ae6e2eec37c8ab8f83ab23e0a948b002a7bfb152b677fd0ec313deb5e70ee5cb37fdd46 SHA512 59e887eddbdf695927e9ece46749f3f62557fd20bb24d7ff109f174a4ae4886cb3b44994903522c1d31c83b9f7f101f16604f6ffc4167ed6405e49a09f236dd0
diff --git a/dev-python/cliff/cliff-3.8.0.ebuild b/dev-python/cliff/cliff-3.8.0.ebuild
deleted file mode 100644
index 0fbb09d634f2..000000000000
--- a/dev-python/cliff/cliff-3.8.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-# TODO: revert to rdepend once this is merged
-# https://github.com/openstack/cliff/pull/3
-DISTUTILS_USE_SETUPTOOLS=manual
-
-inherit distutils-r1
-
-DESCRIPTION="Command Line Interface Formulation Framework"
-HOMEPAGE="https://github.com/openstack/cliff"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
- dev-python/prettytable[${PYTHON_USEDEP}]
- >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests unittest
diff --git a/dev-python/cliff/cliff-3.9.0.ebuild b/dev-python/cliff/cliff-4.6.0.ebuild
index 814c8e563629..c8436db6e065 100644
--- a/dev-python/cliff/cliff-3.9.0.ebuild
+++ b/dev-python/cliff/cliff-4.6.0.ebuild
@@ -1,37 +1,36 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..9} )
-# TODO: revert to rdepend once this is merged
-# https://github.com/openstack/cliff/pull/3
-DISTUTILS_USE_SETUPTOOLS=manual
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="Command Line Interface Formulation Framework"
-HOMEPAGE="https://github.com/openstack/cliff"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="
+ https://opendev.org/openstack/cliff/
+ https://github.com/openstack/cliff/
+ https://pypi.org/project/cliff/
+"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~sparc ~x86"
+KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 sparc x86"
RDEPEND="
>=dev-python/autopage-0.4.0[${PYTHON_USEDEP}]
>=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
dev-python/prettytable[${PYTHON_USEDEP}]
>=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
>=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
"
BDEPEND="
- >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0
- dev-python/setuptools[${PYTHON_USEDEP}]
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
>=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
>=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
diff --git a/dev-python/cliff/metadata.xml b/dev-python/cliff/metadata.xml
index 5742627c8671..d77f98508ed6 100644
--- a/dev-python/cliff/metadata.xml
+++ b/dev-python/cliff/metadata.xml
@@ -17,7 +17,6 @@
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">cliff</remote-id>
- <remote-id type="github">dreamhost/cliff</remote-id>
<remote-id type="github">openstack/cliff</remote-id>
</upstream>
</pkgmetadata>