summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cloudpickle/cloudpickle-0.3.1.ebuild')
-rw-r--r--dev-python/cloudpickle/cloudpickle-0.3.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/cloudpickle/cloudpickle-0.3.1.ebuild b/dev-python/cloudpickle/cloudpickle-0.3.1.ebuild
new file mode 100644
index 000000000000..3c344a15bc7d
--- /dev/null
+++ b/dev-python/cloudpickle/cloudpickle-0.3.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+inherit eutils distutils-r1
+
+DESCRIPTION="Extended pickling support for Python objects"
+HOMEPAGE="https://pypi.python.org/pypi/cloudpickle/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="test"
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+RESTRICT="test"
+
+python_test() {
+ PYTHONPATH='.:tests' py.test || die
+}