summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cmd2/cmd2-0.8.9.ebuild')
-rw-r--r--dev-python/cmd2/cmd2-0.8.9.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/cmd2/cmd2-0.8.9.ebuild b/dev-python/cmd2/cmd2-0.8.9.ebuild
deleted file mode 100644
index bea86e233e12..000000000000
--- a/dev-python/cmd2/cmd2-0.8.9.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{2_7,3_6,3_7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Extra features for standard library's cmd module"
-HOMEPAGE="https://github.com/python-cmd2/cmd2"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm64 ~ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-# restrict tests because pyperclip is fairly unstable...
-RESTRICT="test"
-
-RDEPEND="
- >=dev-python/pyparsing-2.0.1[${PYTHON_USEDEP}]
- dev-python/pyperclip[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/subprocess32[${PYTHON_USEDEP}]' 'python2*')
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- py.test -vv || die
- ${EPYTHON} example/example.py --test example/exampleSession.txt || die
-}