summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/configargparse/configargparse-1.2.2.ebuild')
-rw-r--r--dev-python/configargparse/configargparse-1.2.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/configargparse/configargparse-1.2.2.ebuild b/dev-python/configargparse/configargparse-1.2.2.ebuild
new file mode 100644
index 000000000000..be7d7f5bac5a
--- /dev/null
+++ b/dev-python/configargparse/configargparse-1.2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="ConfigArgParse"
+MY_P="${MY_PN}-${PV}"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Drop-in replacement for argparse supporting config files and env variables"
+HOMEPAGE="https://github.com/bw2/ConfigArgParse https://pypi.org/project/ConfigArgParse/"
+SRC_URI="https://github.com/bw2/ConfigArgParse/archive/${PV}.tar.gz -> ${MY_P}.gh.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? ( dev-python/pyyaml[${PYTHON_USEDEP}] )"
+
+python_test() {
+ local -x COLUMNS=80
+ esetup.py test
+}