summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/configshell-fb')
-rw-r--r--dev-python/configshell-fb/Manifest2
-rw-r--r--dev-python/configshell-fb/configshell-fb-1.1.28.ebuild19
-rw-r--r--dev-python/configshell-fb/configshell-fb-1.1.30.ebuild33
-rw-r--r--dev-python/configshell-fb/metadata.xml47
4 files changed, 54 insertions, 47 deletions
diff --git a/dev-python/configshell-fb/Manifest b/dev-python/configshell-fb/Manifest
index 2e0c19b3316d..4b2c0a5102ae 100644
--- a/dev-python/configshell-fb/Manifest
+++ b/dev-python/configshell-fb/Manifest
@@ -1 +1 @@
-DIST configshell-fb-1.1.28.tar.gz 55076 BLAKE2B 8f7ab1b6172412dffd77d1ba89082f815b90167b5bc7e15c26c26a101e2e8a0ab5bc716c040f41124a9d5a5038b751e4cd882124d70fe2fda2b796ef43dc97c8 SHA512 7d05fdfca5646ec05d5f4b2ea499235237f5f3157c1330ed46dcc76ce8dea5cca0e3ec4d4376db2ec8358438737fb54286cb0c712c0f16637128670d2858dd4d
+DIST configshell-fb-1.1.30.gh.tar.gz 33179 BLAKE2B 8664ec42727fb9bd41600c2844b9b59423c21040e6efc201f40b54abf6d788fa5237d38e2795d0d19706303d99e7ea859b399fd5f122cb04effc643a33b264ac SHA512 b3189130ac047fe28ea987391591b7886f7234864d455a8423d1d65b02a514511e2a32dce1429a6b71cedbc0b7cb6e6e10f29d240b746d222c285f0baa6b46b0
diff --git a/dev-python/configshell-fb/configshell-fb-1.1.28.ebuild b/dev-python/configshell-fb/configshell-fb-1.1.28.ebuild
deleted file mode 100644
index 052c55f212a0..000000000000
--- a/dev-python/configshell-fb/configshell-fb-1.1.28.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-inherit distutils-r1
-
-DESCRIPTION="A Python library for building configuration shells"
-HOMEPAGE="https://github.com/open-iscsi/configshell-fb"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/urwid[${PYTHON_USEDEP}]"
diff --git a/dev-python/configshell-fb/configshell-fb-1.1.30.ebuild b/dev-python/configshell-fb/configshell-fb-1.1.30.ebuild
new file mode 100644
index 000000000000..0265aec51357
--- /dev/null
+++ b/dev-python/configshell-fb/configshell-fb-1.1.30.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python library for building configuration shells"
+HOMEPAGE="
+ https://github.com/open-iscsi/configshell-fb/
+ https://pypi.org/project/configshell-fb/
+"
+SRC_URI="
+ https://github.com/open-iscsi/configshell-fb/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86"
+
+RDEPEND="
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ "${EPYTHON}" examples/myshell || die "Test failed with ${EPYTHON}"
+}
diff --git a/dev-python/configshell-fb/metadata.xml b/dev-python/configshell-fb/metadata.xml
index 26b33bc76426..847c135cf482 100644
--- a/dev-python/configshell-fb/metadata.xml
+++ b/dev-python/configshell-fb/metadata.xml
@@ -1,30 +1,23 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="person" proxied="yes">
- <email>sir.suriv@gmail.com</email>
- <name>Diogo Pereira</name>
-</maintainer>
-<maintainer type="project" proxied="proxy">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
-</maintainer>
-<stabilize-allarches/>
-<longdescription lang="en">
- configshell-fb is a Python library that provides a framework
- for building simple but nice CLI-based applications.
-</longdescription>
-<upstream>
- <maintainer status="active">
- <email>mlombard@redhat.com</email>
- <name>Maurizio Lombardi</name>
- </maintainer>
- <maintainer>
- <email>agrover@redhat.com</email>
- <name>Andy Grover</name>
- </maintainer>
- <remote-id type="github">open-iscsi/configshell-fb</remote-id>
- <remote-id type="pypi">configshell-fb</remote-id>
- <bugs-to>https://github.com/open-iscsi/configshell-fb/issues</bugs-to>
-</upstream>
+ <!-- maintainer-needed -->
+ <stabilize-allarches/>
+ <longdescription lang="en">
+ configshell-fb is a Python library that provides a framework
+ for building simple but nice CLI-based applications.
+ </longdescription>
+ <upstream>
+ <maintainer status="active">
+ <email>mlombard@redhat.com</email>
+ <name>Maurizio Lombardi</name>
+ </maintainer>
+ <maintainer>
+ <email>agrover@redhat.com</email>
+ <name>Andy Grover</name>
+ </maintainer>
+ <remote-id type="github">open-iscsi/configshell-fb</remote-id>
+ <remote-id type="pypi">configshell-fb</remote-id>
+ <bugs-to>https://github.com/open-iscsi/configshell-fb/issues</bugs-to>
+ </upstream>
</pkgmetadata>