summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/configshell-fb')
-rw-r--r--dev-python/configshell-fb/Manifest2
-rw-r--r--dev-python/configshell-fb/configshell-fb-1.1.29.ebuild19
-rw-r--r--dev-python/configshell-fb/configshell-fb-1.1.30.ebuild33
-rw-r--r--dev-python/configshell-fb/metadata.xml38
4 files changed, 53 insertions, 39 deletions
diff --git a/dev-python/configshell-fb/Manifest b/dev-python/configshell-fb/Manifest
index 13fc21a18c1e..4b2c0a5102ae 100644
--- a/dev-python/configshell-fb/Manifest
+++ b/dev-python/configshell-fb/Manifest
@@ -1 +1 @@
-DIST configshell-fb-1.1.29.tar.gz 55036 BLAKE2B 4a9a8f2573b43a9c8ddbda837e831c96b221f4499acb1aeeb990a7b1050c5572e9b745857ac9d1de4089d1758dd1284d0555da524def80e0a1caac18bb43a921 SHA512 0d7663cf58431c8b0be5618e5ef454838489e11a3074e5bd63145c3ea965065e37f1a41b5775363a35498a4d5dd86ad5453feb58dd74853cd77ae196b44c658e
+DIST configshell-fb-1.1.30.gh.tar.gz 33179 BLAKE2B 8664ec42727fb9bd41600c2844b9b59423c21040e6efc201f40b54abf6d788fa5237d38e2795d0d19706303d99e7ea859b399fd5f122cb04effc643a33b264ac SHA512 b3189130ac047fe28ea987391591b7886f7234864d455a8423d1d65b02a514511e2a32dce1429a6b71cedbc0b7cb6e6e10f29d240b746d222c285f0baa6b46b0
diff --git a/dev-python/configshell-fb/configshell-fb-1.1.29.ebuild b/dev-python/configshell-fb/configshell-fb-1.1.29.ebuild
deleted file mode 100644
index 3cf06559f03a..000000000000
--- a/dev-python/configshell-fb/configshell-fb-1.1.29.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="A Python library for building configuration shells"
-HOMEPAGE="https://github.com/open-iscsi/configshell-fb"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/urwid[${PYTHON_USEDEP}]"
diff --git a/dev-python/configshell-fb/configshell-fb-1.1.30.ebuild b/dev-python/configshell-fb/configshell-fb-1.1.30.ebuild
new file mode 100644
index 000000000000..0265aec51357
--- /dev/null
+++ b/dev-python/configshell-fb/configshell-fb-1.1.30.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python library for building configuration shells"
+HOMEPAGE="
+ https://github.com/open-iscsi/configshell-fb/
+ https://pypi.org/project/configshell-fb/
+"
+SRC_URI="
+ https://github.com/open-iscsi/configshell-fb/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86"
+
+RDEPEND="
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ "${EPYTHON}" examples/myshell || die "Test failed with ${EPYTHON}"
+}
diff --git a/dev-python/configshell-fb/metadata.xml b/dev-python/configshell-fb/metadata.xml
index 43d40de7baa2..847c135cf482 100644
--- a/dev-python/configshell-fb/metadata.xml
+++ b/dev-python/configshell-fb/metadata.xml
@@ -1,23 +1,23 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
-<stabilize-allarches/>
-<longdescription lang="en">
- configshell-fb is a Python library that provides a framework
- for building simple but nice CLI-based applications.
-</longdescription>
-<upstream>
- <maintainer status="active">
- <email>mlombard@redhat.com</email>
- <name>Maurizio Lombardi</name>
- </maintainer>
- <maintainer>
- <email>agrover@redhat.com</email>
- <name>Andy Grover</name>
- </maintainer>
- <remote-id type="github">open-iscsi/configshell-fb</remote-id>
- <remote-id type="pypi">configshell-fb</remote-id>
- <bugs-to>https://github.com/open-iscsi/configshell-fb/issues</bugs-to>
-</upstream>
+ <!-- maintainer-needed -->
+ <stabilize-allarches/>
+ <longdescription lang="en">
+ configshell-fb is a Python library that provides a framework
+ for building simple but nice CLI-based applications.
+ </longdescription>
+ <upstream>
+ <maintainer status="active">
+ <email>mlombard@redhat.com</email>
+ <name>Maurizio Lombardi</name>
+ </maintainer>
+ <maintainer>
+ <email>agrover@redhat.com</email>
+ <name>Andy Grover</name>
+ </maintainer>
+ <remote-id type="github">open-iscsi/configshell-fb</remote-id>
+ <remote-id type="pypi">configshell-fb</remote-id>
+ <bugs-to>https://github.com/open-iscsi/configshell-fb/issues</bugs-to>
+ </upstream>
</pkgmetadata>