summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/construct')
-rw-r--r--dev-python/construct/Manifest2
-rw-r--r--dev-python/construct/construct-2.10.56.ebuild35
-rw-r--r--dev-python/construct/construct-2.10.70.ebuild41
-rw-r--r--dev-python/construct/metadata.xml5
4 files changed, 45 insertions, 38 deletions
diff --git a/dev-python/construct/Manifest b/dev-python/construct/Manifest
index 669e2ab0547f..41804c38ca03 100644
--- a/dev-python/construct/Manifest
+++ b/dev-python/construct/Manifest
@@ -1 +1 @@
-DIST construct-2.10.56.tar.gz 1184110 BLAKE2B 01ce1800970826ae3584a9733de171e04dd926e7d19d8b48b4364406b4aa0f4d878ec52f9a7f755bb249aeeaca75ae6221d6bdf302d4342d4974d268b1782175 SHA512 cc9aa126c26a017a3fb7b78a6b8f2056194028a44c8ed615a6dc4a445d50f0463e2de0b80810ab5a252070925a56b5a61dbb601a3de9e445d861356231a146d5
+DIST construct-2.10.70.gh.tar.gz 1196623 BLAKE2B 98206e9fbf65c208172cfc4ac983c636fe022a51891a9d8f784c87656d2143f97fd7ec108cc24ca857a589479fe5ca17beb8db245c300d5bb90fdfd2859e5801 SHA512 1c4fe99d36266bf68f4876fdaea5b7cbbb2ea202b73cf4b54f92b443cd753200aec52a15ff97001c9e040b3c16ecc8dd444bbac26f7860100087e430beab1f81
diff --git a/dev-python/construct/construct-2.10.56.ebuild b/dev-python/construct/construct-2.10.56.ebuild
deleted file mode 100644
index f8b0e77516dc..000000000000
--- a/dev-python/construct/construct-2.10.56.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8,9} )
-
-inherit distutils-r1
-
-DESCRIPTION="A powerful declarative parser for binary data"
-HOMEPAGE="https://construct.readthedocs.io/en/latest/ https://pypi.org/project/construct/"
-SRC_URI="https://github.com/construct/construct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-distutils_enable_tests pytest
-BDEPEND+="
- test? (
- dev-python/arrow[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.15.4[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- )"
-
-src_prepare() {
- default
- rm tests/test_benchmarks.py || die
-}
-
-pkg_postinst() {
- ewarn "Version 2.10.x has significant API and implementation changes from"
- ewarn "previous 2.9.x releases. Please read the documentation at"
- ewarn "https://construct.readthedocs.io/en/latest/transition210.html"
- ewarn "for more info."
-}
diff --git a/dev-python/construct/construct-2.10.70.ebuild b/dev-python/construct/construct-2.10.70.ebuild
new file mode 100644
index 000000000000..c21fb48b82dc
--- /dev/null
+++ b/dev-python/construct/construct-2.10.70.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A powerful declarative parser for binary data"
+HOMEPAGE="
+ https://construct.readthedocs.io/en/latest/
+ https://github.com/construct/construct/
+ https://pypi.org/project/construct/
+"
+SRC_URI="
+ https://github.com/construct/construct/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm64 x86"
+
+BDEPEND="
+ test? (
+ dev-python/arrow[${PYTHON_USEDEP}]
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/lz4[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.4[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ tests/test_benchmarks.py
+)
diff --git a/dev-python/construct/metadata.xml b/dev-python/construct/metadata.xml
index d884045ff57e..41f9b2bbd44b 100644
--- a/dev-python/construct/metadata.xml
+++ b/dev-python/construct/metadata.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
- <maintainer type="person">
+ <maintainer type="person" proxied="yes">
<email>azamat.hackimov@gmail.com</email>
<name>Azamat H. Hackimov</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="github">construct/construct</remote-id>
<remote-id type="pypi">construct</remote-id>