summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/couchdb-python')
-rw-r--r--dev-python/couchdb-python/Manifest3
-rw-r--r--dev-python/couchdb-python/couchdb-python-0.10.ebuild47
-rw-r--r--dev-python/couchdb-python/couchdb-python-0.9.ebuild34
-rw-r--r--dev-python/couchdb-python/couchdb-python-1.0.ebuild44
-rw-r--r--dev-python/couchdb-python/files/0.10-exec-compat.patch87
-rw-r--r--dev-python/couchdb-python/metadata.xml13
6 files changed, 228 insertions, 0 deletions
diff --git a/dev-python/couchdb-python/Manifest b/dev-python/couchdb-python/Manifest
new file mode 100644
index 000000000000..caeef0ee2950
--- /dev/null
+++ b/dev-python/couchdb-python/Manifest
@@ -0,0 +1,3 @@
+DIST CouchDB-0.10.tar.gz 56547 SHA256 dd477d8c535a324d763b34beb0d296cf660c98090666a06956b5b98d9a69c960 SHA512 73655b173e497cde58f8bd3d648f28b6189363bccea68454ea60c851a73933d94e90f357a4969694f72c3034dac5166b351f7d68290ff458860f19a2d669bab5 WHIRLPOOL cee3cb74435955384297d84f09da9132f34b2d404868b094df80fc46770c1cc8cbd83cdc9ac70f668610a9d34ac18790084eaeb68bb863913f239a694990f3fa
+DIST CouchDB-0.9.tar.gz 55189 SHA256 a1cf5071b5adb47048199bbfbaf1500e69c88b27afe14ba26efa0f4044c3baee SHA512 ceba7afd3400e9da51fb6493b68d5192e1c3817d159fc8f2791bdc03b61828f1b2f262a64832e81f4b950379795b100c8f506527489e91a8872291a7b4173c42 WHIRLPOOL ddace810c3e879a6cba84602999fc964b4681a56a838d2e5e301b23ce76c94c99fb1936cbb8426f1d276a42b937755b39adaf206c7e60738799bf8add6deb7be
+DIST CouchDB-1.0.tar.gz 56791 SHA256 f81de35433932e1d81b922d12119fe9b2435046db5dc53d1fb068a087c1fb264 SHA512 c328a9b027d24ee560ef592925a072a463852fdb7e8e93e1d6e740d7245181ba147985d610d6fd55f4790d7338e69470c44f574469e718eeb7b4163dfb6fc19a WHIRLPOOL 326be4bedd76ebbc5c9fd3cbdc52182230e0701372e75fa074a328633668e407528ccab7d3516b665be8587d131db4e7f7ba054cb6be2fca60b16265793f38c4
diff --git a/dev-python/couchdb-python/couchdb-python-0.10.ebuild b/dev-python/couchdb-python/couchdb-python-0.10.ebuild
new file mode 100644
index 000000000000..8cc0d4e6ff88
--- /dev/null
+++ b/dev-python/couchdb-python/couchdb-python-0.10.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_PN="CouchDB"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python library for working with CouchDB"
+HOMEPAGE="http://code.google.com/p/couchdb-python/ http://pypi.python.org/pypi/CouchDB"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
+
+# Tests require connectivity to a couchdb server.
+# Re-enable when the ebuild is capable of starting a local couchdb
+# instance.
+RESTRICT=test
+
+PATCHES=( "${FILESDIR}/${PV}-exec-compat.patch" )
+
+python_compile_all() {
+ esetup.py build_sphinx
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/couchdb-python/couchdb-python-0.9.ebuild b/dev-python/couchdb-python/couchdb-python-0.9.ebuild
new file mode 100644
index 000000000000..435d2ec3265d
--- /dev/null
+++ b/dev-python/couchdb-python/couchdb-python-0.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="CouchDB"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python library for working with CouchDB"
+HOMEPAGE="http://code.google.com/p/couchdb-python/ http://pypi.python.org/pypi/CouchDB"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
+
+# Tests require connectivity to a couchdb server.
+# Re-enable when the ebuild is capable of starting a local couchdb
+# instance.
+RESTRICT=test
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/couchdb-python/couchdb-python-1.0.ebuild b/dev-python/couchdb-python/couchdb-python-1.0.ebuild
new file mode 100644
index 000000000000..63278c2e505c
--- /dev/null
+++ b/dev-python/couchdb-python/couchdb-python-1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_PN="CouchDB"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python library for working with CouchDB"
+HOMEPAGE="https://github.com/djc/couchdb-python http://pypi.python.org/pypi/CouchDB"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+# Tests require connectivity to a couchdb server.
+# Re-enable when the ebuild is capable of starting a local couchdb
+# instance.
+RESTRICT=test
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/couchdb-python/files/0.10-exec-compat.patch b/dev-python/couchdb-python/files/0.10-exec-compat.patch
new file mode 100644
index 000000000000..da0ad536e113
--- /dev/null
+++ b/dev-python/couchdb-python/files/0.10-exec-compat.patch
@@ -0,0 +1,87 @@
+commit 8fdba0f09df00d69618858c70d11ddbeecd30026
+Author: Dirkjan Ochtman <dirkjan@ochtman.nl>
+Date: Thu Jul 24 11:43:52 2014 +0200
+
+ Use a single pyexec() utility function to fix compatibility issues
+
+ While the current setup (where 2.x uses the exec statement and 3.x uses the
+ exec() function) works at run-time, it causes problem while byte-compiling
+ the util modules for their non-appropriate interpreter versions:
+
+ File "/usr/lib64/python2.7/site-packages/couchdb/util3.py", line 17
+ pyexec = exec
+ ^
+ SyntaxError: invalid syntax
+
+ File "/usr/lib64/python3.3/site-packages/couchdb/util2.py", line 19
+ exec code in gns, lns
+ ^
+ SyntaxError: invalid syntax
+
+ There doesn't appear to be an easy way to exclude some files from installation
+ based on the installing Python version, but it turns out the 2.x exec
+ statement can also take its arguments as a tuple, such that the 2.x and 3.x
+ versions can be used with the same syntax.
+
+ However, Python 2.7 has a bug (#21591) that prevents this from working in the
+ context we use exec in (in a function that also contains a nested function),
+ due to a bad implementation that enables the arguments-as-tuple functionality.
+ We thus need a helper function after all, to pull it out of that context.
+
+diff --git a/couchdb/util.py b/couchdb/util.py
+index bdd52f3..d111a6b 100644
+--- a/couchdb/util.py
++++ b/couchdb/util.py
+@@ -4,3 +4,7 @@ if sys.version_info[0] < 3:
+ from couchdb.util2 import *
+ else:
+ from couchdb.util3 import *
++
++def pyexec(code, gns, lns):
++ # http://bugs.python.org/issue21591
++ exec(code, gns, lns)
+diff --git a/couchdb/util2.py b/couchdb/util2.py
+index ad1b0a8..03fd558 100644
+--- a/couchdb/util2.py
++++ b/couchdb/util2.py
+@@ -1,8 +1,7 @@
+
+ __all__ = [
+ 'StringIO', 'urlsplit', 'urlunsplit', 'urlquote', 'urlunquote',
+- 'urlencode', 'utype', 'ltype', 'pyexec', 'strbase', 'funcode',
+- 'urlparse',
++ 'urlencode', 'utype', 'ltype', 'strbase', 'funcode', 'urlparse',
+ ]
+
+ utype = unicode
+@@ -15,8 +14,5 @@ from urllib import quote as urlquote
+ from urllib import unquote as urlunquote
+ from urllib import urlencode
+
+-def pyexec(code, gns, lns):
+- exec code in gns, lns
+-
+ def funcode(fun):
+ return fun.func_code
+diff --git a/couchdb/util3.py b/couchdb/util3.py
+index c2e46d6..6bf84f0 100644
+--- a/couchdb/util3.py
++++ b/couchdb/util3.py
+@@ -1,8 +1,7 @@
+
+ __all__ = [
+ 'StringIO', 'urlsplit', 'urlunsplit', 'urlquote', 'urlunquote',
+- 'urlencode', 'utype', 'ltype', 'pyexec', 'strbase', 'funcode',
+- 'urlparse',
++ 'urlencode', 'utype', 'ltype', 'strbase', 'funcode', 'urlparse',
+ ]
+
+ utype = str
+@@ -14,7 +13,5 @@ from urllib.parse import urlsplit, urlunsplit, urlencode, urlparse
+ from urllib.parse import quote as urlquote
+ from urllib.parse import unquote as urlunquote
+
+-pyexec = exec
+-
+ def funcode(fun):
+ return fun.__code__
diff --git a/dev-python/couchdb-python/metadata.xml b/dev-python/couchdb-python/metadata.xml
new file mode 100644
index 000000000000..805dbec4a0d1
--- /dev/null
+++ b/dev-python/couchdb-python/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>djc@gentoo.org</email>
+ <name>Dirkjan Ochtman</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">CouchDB</remote-id>
+ <remote-id type="github">djc/couchdb-python</remote-id>
+ </upstream>
+</pkgmetadata>