summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cppy/cppy-1.2.0.ebuild')
-rw-r--r--dev-python/cppy/cppy-1.2.0.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/cppy/cppy-1.2.0.ebuild b/dev-python/cppy/cppy-1.2.0.ebuild
new file mode 100644
index 000000000000..768ec61a39ba
--- /dev/null
+++ b/dev-python/cppy/cppy-1.2.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="C++ header library which makes it easier to write Python extension modules"
+HOMEPAGE="https://pypi.org/project/cppy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest