summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/crashtest/crashtest-0.3.1-r1.ebuild')
-rw-r--r--dev-python/crashtest/crashtest-0.3.1-r1.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/crashtest/crashtest-0.3.1-r1.ebuild b/dev-python/crashtest/crashtest-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..4ad830f6d949
--- /dev/null
+++ b/dev-python/crashtest/crashtest-0.3.1-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python library that makes exceptions handling and inspection easier"
+HOMEPAGE="https://github.com/sdispater/crashtest"
+SRC_URI="https://github.com/sdispater/crashtest/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+distutils_enable_tests pytest