summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/croniter/croniter-0.3.29.ebuild')
-rw-r--r--dev-python/croniter/croniter-0.3.29.ebuild27
1 files changed, 0 insertions, 27 deletions
diff --git a/dev-python/croniter/croniter-0.3.29.ebuild b/dev-python/croniter/croniter-0.3.29.ebuild
deleted file mode 100644
index debbc4fd5e47..000000000000
--- a/dev-python/croniter/croniter-0.3.29.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python module to provide iteration for datetime object"
-HOMEPAGE="https://github.com/kiorky/croniter https://pypi.org/project/croniter/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- )"
-RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]"
-python_test() {
- py.test -v src/croniter/tests || die "tests failed"
-}