summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cx_Freeze/files/cx_Freeze-4.3.4-buildsystem.patch')
-rw-r--r--dev-python/cx_Freeze/files/cx_Freeze-4.3.4-buildsystem.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/dev-python/cx_Freeze/files/cx_Freeze-4.3.4-buildsystem.patch b/dev-python/cx_Freeze/files/cx_Freeze-4.3.4-buildsystem.patch
new file mode 100644
index 000000000000..e55d0d324c30
--- /dev/null
+++ b/dev-python/cx_Freeze/files/cx_Freeze-4.3.4-buildsystem.patch
@@ -0,0 +1,16 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Tue Nov 19 11:20:21 UTC 2013
+
+Respect LDFLAGS, remove stripping.
+Fixes Gentoo bug #491602
+
+--- a/setup.py
++++ b/setup.py
+@@ -94,7 +94,6 @@
+ extraArgs.extend(vars["BASEMODLIBS"].split())
+ if vars["LOCALMODLIBS"]:
+ extraArgs.extend(vars["LOCALMODLIBS"].split())
+- extraArgs.append("-s")
+ self.compiler.link_executable(objects, fullName,
+ libraries = libraries,
+ library_dirs = libraryDirs,