summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/deprecated')
-rw-r--r--dev-python/deprecated/Manifest2
-rw-r--r--dev-python/deprecated/deprecated-1.2.12.ebuild32
-rw-r--r--dev-python/deprecated/deprecated-1.2.14.ebuild27
-rw-r--r--dev-python/deprecated/metadata.xml3
4 files changed, 30 insertions, 34 deletions
diff --git a/dev-python/deprecated/Manifest b/dev-python/deprecated/Manifest
index aabed087e350..cae2216ad75a 100644
--- a/dev-python/deprecated/Manifest
+++ b/dev-python/deprecated/Manifest
@@ -1 +1 @@
-DIST deprecated-1.2.12.gh.tar.gz 2969891 BLAKE2B c5fe02ff2c0588c5c6fb1e9054ad7851943c4574be633aa6ae37a466b3cac9889d8ed119962fcffc2092ab844a6d18a5d72766141e149bba2ba0c2dd4ee5131b SHA512 ff9b03a35b688474b6d5390347c4acdf5e19fcee5f7fcbb61a456c6819adbcda72ce00200d55b92c65873addad5abf9d1d5617bf477f64beb08ca23f10ebaea2
+DIST Deprecated-1.2.14.tar.gz 2974416 BLAKE2B d7994a435f7709a74fde71b1bfe20aaec44813893fd8d9fba70b55938ec2dcb01364a0084e5b161ad84819a6ce258ef28813f7272c9cc48cfc8a2159408b5f29 SHA512 5c2f71fc4c1abb6d4a6913bd9644d47d12f709a0830b2aa3513aa2aa92c13e916c49fcd45a5f38aa29279822a5bb8563c4062e5f3e21bb6c55ca97b7845ee736
diff --git a/dev-python/deprecated/deprecated-1.2.12.ebuild b/dev-python/deprecated/deprecated-1.2.12.ebuild
deleted file mode 100644
index a0b370872579..000000000000
--- a/dev-python/deprecated/deprecated-1.2.12.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Python @deprecated decorator to deprecate old API"
-HOMEPAGE="https://github.com/tantale/deprecated"
-SRC_URI="
- https://github.com/tantale/deprecated/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-
-RDEPEND="dev-python/wrapt[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=()
-
- [[ ${EPYTHON} == pypy3 ]] && deselect+=(
- tests/test_deprecated.py::test_respect_global_filter
- tests/test_deprecated_class.py::test_class_respect_global_filter
- )
-
- pytest -vv ${deselect[@]/#/--deselect } || die "Tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/deprecated/deprecated-1.2.14.ebuild b/dev-python/deprecated/deprecated-1.2.14.ebuild
new file mode 100644
index 000000000000..2503a4b7b259
--- /dev/null
+++ b/dev-python/deprecated/deprecated-1.2.14.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python @deprecated decorator to deprecate old API"
+HOMEPAGE="
+ https://github.com/tantale/deprecated/
+ https://pypi.org/project/Deprecated/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND="
+ dev-python/wrapt[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/deprecated/metadata.xml b/dev-python/deprecated/metadata.xml
index 9e1c60a102ff..c45ae963f499 100644
--- a/dev-python/deprecated/metadata.xml
+++ b/dev-python/deprecated/metadata.xml
@@ -1,11 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>python@gentoo.org</email>
</maintainer>
<stabilize-allarches/>
<upstream>
+ <remote-id type="github">tantale/deprecated</remote-id>
<remote-id type="pypi">Deprecated</remote-id>
</upstream>
</pkgmetadata>