summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/deprecated')
-rw-r--r--dev-python/deprecated/Manifest1
-rw-r--r--dev-python/deprecated/deprecated-1.2.9.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/deprecated/Manifest b/dev-python/deprecated/Manifest
index 8c92df6b67a5..410e9e8ea9e2 100644
--- a/dev-python/deprecated/Manifest
+++ b/dev-python/deprecated/Manifest
@@ -1 +1,2 @@
DIST deprecated-1.2.7.gh.tar.gz 5044697 BLAKE2B 5e295ce21a3e536e08b6e57d78d3682b31e9041f4c53d97c06af03f8272a5b729c892449210471b80500ce499fe9e6af22df8ac0aeec5ac774fd74590ebdfc3b SHA512 da99a22410fdcc2a96cb5b15c489971078ce34e251406ae3dce6b3f97e284a4f09aaf1c5702407abe85a94cb6c8d9237f373a3096d6182e4a9cd1990be2817f1
+DIST deprecated-1.2.9.gh.tar.gz 5332765 BLAKE2B 0b88c15a0186d3adcfe3076a477e1bce3565caf39feb8e25c28865d85a168ed4cecda33fd68158571ebaed429e61b2de290f0c7e832dc87baa9cd4d439dcb093 SHA512 04a248d78021c45a1254f80966e6e4e6817ff3f8312d36fa9874c300fc106b7bed3600702a6953044f88cfa08f8ea8d6447c160554d8c1e1568051d3ce4a175b
diff --git a/dev-python/deprecated/deprecated-1.2.9.ebuild b/dev-python/deprecated/deprecated-1.2.9.ebuild
new file mode 100644
index 000000000000..a5088d2c205c
--- /dev/null
+++ b/dev-python/deprecated/deprecated-1.2.9.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Python @deprecated decorator to deprecate old API"
+HOMEPAGE="https://github.com/tantale/deprecated"
+SRC_URI="https://github.com/tantale/deprecated/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/wrapt[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest