summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/deprecation')
-rw-r--r--dev-python/deprecation/Manifest2
-rw-r--r--dev-python/deprecation/deprecation-1.0.1.ebuild19
-rw-r--r--dev-python/deprecation/deprecation-2.0.6.ebuild31
3 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/deprecation/Manifest b/dev-python/deprecation/Manifest
index 6f805c69365c..c9974089d590 100644
--- a/dev-python/deprecation/Manifest
+++ b/dev-python/deprecation/Manifest
@@ -1,3 +1 @@
-DIST deprecation-1.0.1.tar.gz 9596 BLAKE2B afc4cb457ce224f120d41944e6eb71c212ef4d40d5a7c5d6d695d31bd105a4a5291daf5d3c7af0f94b58049f7e745e7e5be462495de88c48cabf5a28c22b3637 SHA512 fc35e6516e1617e2baad598a91e5d83ca95ab8a2d6a2753751d6752675de93cb44210109450a2aad9eb52b3c772a8b753c1d42ab2356c6663d2a03c4f779f086
-DIST deprecation-2.0.6.tar.gz 13381 BLAKE2B 1f21a4b8bd9293d50e9068762d4f909afe02fb1f7a8f352c5b3d5d10e0da90d122927a97cf060bec626ff8538478f83740dc1d79e050fe43dc27ade8729f26d1 SHA512 69dcf5e07cfc1c746564e03063088cce65690e2b34cffe327d59edad24f00d23cf9904089ab9ff5e67dce2b6b02ed617e53959be4a907074440ddb778576aa2f
DIST deprecation-2.0.7.tar.gz 17077 BLAKE2B da3fb5db53f281c29e2af40335ef4038e37d133563b85d0ea795a314fd9f2d725a98c100aca338dc9ebe60bb1000476e0debcfdc9c4583108004df207cb36747 SHA512 4412e2e95f4aa4b3d5598346a6649c8d945d7401ac2d0fba3b6f6eef567403c8454ebe537e8de646903cd0c2308f48ecb949dae3015ba7617edd2fa3a26ed429
diff --git a/dev-python/deprecation/deprecation-1.0.1.ebuild b/dev-python/deprecation/deprecation-1.0.1.ebuild
deleted file mode 100644
index 54100da58a3a..000000000000
--- a/dev-python/deprecation/deprecation-1.0.1.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-inherit distutils-r1
-
-DESCRIPTION="A library to handle automated deprecations"
-HOMEPAGE="https://deprecation.readthedocs.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
diff --git a/dev-python/deprecation/deprecation-2.0.6.ebuild b/dev-python/deprecation/deprecation-2.0.6.ebuild
deleted file mode 100644
index 6d059b817144..000000000000
--- a/dev-python/deprecation/deprecation-2.0.6.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="A library to handle automated deprecations"
-HOMEPAGE="https://deprecation.readthedocs.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/packaging[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/unittest2[${PYTHON_USEDEP}]
- ${RDEPEND}
- )
-"
-
-python_test() {
- "${EPYTHON}" -m unittest discover -v || die "tests failed with ${EPYTHON}"
-}