summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/diskcache')
-rw-r--r--dev-python/diskcache/Manifest3
-rw-r--r--dev-python/diskcache/diskcache-5.2.1-r1.ebuild42
-rw-r--r--dev-python/diskcache/diskcache-5.6.3.ebuild (renamed from dev-python/diskcache/diskcache-5.3.0.ebuild)28
3 files changed, 15 insertions, 58 deletions
diff --git a/dev-python/diskcache/Manifest b/dev-python/diskcache/Manifest
index c2ea80f79d8c..880f19ebbc19 100644
--- a/dev-python/diskcache/Manifest
+++ b/dev-python/diskcache/Manifest
@@ -1,2 +1 @@
-DIST diskcache-5.2.1.gh.tar.gz 652769 BLAKE2B 25fcdcf51c8be7a6e2a9de645258f776647789a7f06c70c8564ad28bd003a745167095b11a54d435e733d9f5181a1443be2510fe2d901cc208ea426d3359c0ba SHA512 6e55bada12145d931f4a465092decc3f2cfed2e618d1ea271ad6daa6caf7c3abfd6ae5de11072efdf898ebf272acd39136136b58d7b5e735092963bdd46af52e
-DIST diskcache-5.3.0.gh.tar.gz 653506 BLAKE2B 250420da434fa8a02cf58ed552072cb62a6d10dfa3801cf187db327a687763ab7f010c19f5e10b9ba71b2fd6830ba902750ca273c8be08c6f7987aa0923afcff SHA512 106c8eb8320153e42e076927d51fa75d30b92156e17a75756e0392028cb6b5054af9af66b93aa69b7a7105012f0b92fe942ee447a75e53e005b56eb0b067dc38
+DIST diskcache-5.6.3.gh.tar.gz 655441 BLAKE2B bc2495862fec7dfffd50e84a7d68e04f42ae8f29c2273466a81e1ec8e82af33a8af3a1f40ac06563c656e48ea24e936402f6269ac498f8521b096e6457aa8df8 SHA512 476d677d88212aa3f9a6e8d12c3e7076cc6a06973d703ed0b2c550b4b4e916b24fb7d8f33c7174854015886fab26e2707b134328d2bc3e144aef5510e7bc0f7c
diff --git a/dev-python/diskcache/diskcache-5.2.1-r1.ebuild b/dev-python/diskcache/diskcache-5.2.1-r1.ebuild
deleted file mode 100644
index c265840ce885..000000000000
--- a/dev-python/diskcache/diskcache-5.2.1-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-HOMEPAGE="http://www.grantjenks.com/docs/diskcache/
- https://github.com/grantjenks/python-diskcache/"
-DESCRIPTION="Disk and file backed cache"
-SRC_URI="
- https://github.com/grantjenks/python-diskcache/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-S=${WORKDIR}/python-diskcache-${PV}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-src_prepare() {
- # remove dep on pytest-xdist and pytest-cov
- sed -i -e '/-n auto/d' -e '/--cov/d' tox.ini || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local ignore=(
- # django tests don't work with django-3.2, and django-3.1
- # doesn't work with py3.10
- tests/test_djangocache.py
- tests/test_doctest.py
- README.rst
- )
- epytest ${ignore[@]/#/--ignore }
-}
diff --git a/dev-python/diskcache/diskcache-5.3.0.ebuild b/dev-python/diskcache/diskcache-5.6.3.ebuild
index d80cb066da0b..6b1e9708ca28 100644
--- a/dev-python/diskcache/diskcache-5.3.0.ebuild
+++ b/dev-python/diskcache/diskcache-5.6.3.ebuild
@@ -1,39 +1,39 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="sqlite"
inherit distutils-r1
-HOMEPAGE="http://www.grantjenks.com/docs/diskcache/
- https://github.com/grantjenks/python-diskcache/"
+HOMEPAGE="
+ https://grantjenks.com/docs/diskcache/
+ https://github.com/grantjenks/python-diskcache/
+ https://pypi.org/project/diskcache/
+"
DESCRIPTION="Disk and file backed cache"
SRC_URI="
https://github.com/grantjenks/python-diskcache/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
+ -> ${P}.gh.tar.gz
+"
S=${WORKDIR}/python-diskcache-${PV}
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
BDEPEND="
test? (
- dev-python/django[${PYTHON_USEDEP}]
- )"
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+ )
+"
distutils_enable_sphinx docs
distutils_enable_tests pytest
-EPYTEST_DESELECT=(
- # TODO
- tests/test_djangocache.py::DiskCacheTests::test_get_or_set_callable_returning_none
- tests/test_djangocache.py::DiskCacheTests::test_pickle
-)
-
src_prepare() {
# remove dep on pytest-xdist and pytest-cov
sed -i -e '/-n auto/d' -e '/--cov/d' tox.ini || die