summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/diskcache')
-rw-r--r--dev-python/diskcache/Manifest3
-rw-r--r--dev-python/diskcache/diskcache-4.1.0.ebuild48
-rw-r--r--dev-python/diskcache/diskcache-5.0.1.ebuild37
-rw-r--r--dev-python/diskcache/diskcache-5.0.2.ebuild37
4 files changed, 0 insertions, 125 deletions
diff --git a/dev-python/diskcache/Manifest b/dev-python/diskcache/Manifest
index d86a0130032a..d82cad07665f 100644
--- a/dev-python/diskcache/Manifest
+++ b/dev-python/diskcache/Manifest
@@ -1,4 +1 @@
-DIST diskcache-4.1.0.gh.tar.gz 658268 BLAKE2B 7712892a15e0f7b34b05c48071b4ed22f94ff4c8b6e66dff5591296d7186c686958ef3ec19994b6965319ba3e601850a1782f7ac8ed09090afda4b75ae16a12b SHA512 3871e56fa9a50942e29e200df74d7f4312d21a0f51d6be2041ce71efd3c1d0c204cc1df5ac1f92825314c742bb48bf8b0a3929cee225055903953e095701c8e3
-DIST diskcache-5.0.1.gh.tar.gz 656475 BLAKE2B 1926dd40564130a24f211a1962c9a9e4ecc640ecd55d2bae5057ead787df0cc64634be8a798202702a7810612bece0d45202bb12d495da1863c8b10e645cb7fa SHA512 9e06427e8ff158fa186ed161b7e90980f1a1d866164d6018a522f80a323be981f99e4297b0d90106dfb08b5d2d0babcb5a2dafebcc194e2c282c30bcf3e0f1a1
-DIST diskcache-5.0.2.gh.tar.gz 656471 BLAKE2B d4aa7859bbefdd5aedf8bfd81ee9763890371a7667216a0d4a1728d5eacb643749adfb9f7324745f67c145ed6d61f50c449d1cc20ac9b77386aacad639fe1856 SHA512 79fc94be90517a55cd94f67b5c33279925beaf6cc38027c26603b67527b49976c3aaa80368db2671cce7deb4e933aacb8f89ed85dafe3cdc2f99862b2b49471c
DIST diskcache-5.0.3.gh.tar.gz 656486 BLAKE2B be3a7c919287698e4bd7fc6ff4b861729eabeddff47d01f08711f75f72a48d652e798ed511c5aa1cd9952ecbbbd5ebb003663cfd9c0877b812ef421665e080c0 SHA512 41b393ce255747939c68059251c31b5af43ad9c7fbcfe9288193c501a3a7d070b8db0863e1abd10f16db574565719b2357a7b10371428ed3f37f7de754b16ab6
diff --git a/dev-python/diskcache/diskcache-4.1.0.ebuild b/dev-python/diskcache/diskcache-4.1.0.ebuild
deleted file mode 100644
index 9f91b9ac968d..000000000000
--- a/dev-python/diskcache/diskcache-4.1.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-HOMEPAGE="http://www.grantjenks.com/docs/diskcache/
- https://github.com/grantjenks/python-diskcache/"
-DESCRIPTION="Disk and file backed cache"
-SRC_URI="
- https://github.com/grantjenks/python-diskcache/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-S=${WORKDIR}/python-diskcache-${PV}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
-
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-src_prepare() {
- # remove dep on pytest-xdist
- sed -i -e '/-n auto/d' tox.ini || die
- # requires django-1.1*
- rm diskcache/djangocache.py || die
- sed -e '/diskcache\.djangocache/d' \
- -e 's:test_djangocache:_&:' \
- -i tests/test_doctest.py || die
- rm tests/test_djangocache.py || die
-
- distutils-r1_src_prepare
-}
-
-pkg_postinst() {
- elog "Please note that the Gentoo package does not install the djangocache"
- elog "submodule as it requires old version of dev-python/django."
-}
diff --git a/dev-python/diskcache/diskcache-5.0.1.ebuild b/dev-python/diskcache/diskcache-5.0.1.ebuild
deleted file mode 100644
index c07ed748a131..000000000000
--- a/dev-python/diskcache/diskcache-5.0.1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-HOMEPAGE="http://www.grantjenks.com/docs/diskcache/
- https://github.com/grantjenks/python-diskcache/"
-DESCRIPTION="Disk and file backed cache"
-SRC_URI="
- https://github.com/grantjenks/python-diskcache/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-S=${WORKDIR}/python-diskcache-${PV}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
-
-BDEPEND="
- test? (
- >=dev-python/django-2.2[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-src_prepare() {
- # remove dep on pytest-xdist
- sed -i -e '/-n auto/d' tox.ini || die
-
- distutils-r1_src_prepare
-}
diff --git a/dev-python/diskcache/diskcache-5.0.2.ebuild b/dev-python/diskcache/diskcache-5.0.2.ebuild
deleted file mode 100644
index c57b662ad91a..000000000000
--- a/dev-python/diskcache/diskcache-5.0.2.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-HOMEPAGE="http://www.grantjenks.com/docs/diskcache/
- https://github.com/grantjenks/python-diskcache/"
-DESCRIPTION="Disk and file backed cache"
-SRC_URI="
- https://github.com/grantjenks/python-diskcache/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-S=${WORKDIR}/python-diskcache-${PV}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
-
-BDEPEND="
- test? (
- >=dev-python/django-2.2[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-src_prepare() {
- # remove dep on pytest-xdist
- sed -i -e '/-n auto/d' tox.ini || die
-
- distutils-r1_src_prepare
-}