summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dissononce/dissononce-0.34.3-r1.ebuild')
-rw-r--r--dev-python/dissononce/dissononce-0.34.3-r1.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/dissononce/dissononce-0.34.3-r1.ebuild b/dev-python/dissononce/dissononce-0.34.3-r1.ebuild
deleted file mode 100644
index 18e6ecea9dd4..000000000000
--- a/dev-python/dissononce/dissononce-0.34.3-r1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS="bdepend"
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="A python implementation for Noise Protocol Framework"
-HOMEPAGE="https://github.com/tgalal/dissononce"
-SRC_URI="https://github.com/tgalal/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="examples test"
-
-RDEPEND="
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/transitions[${PYTHON_USEDEP}]
-"
-
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}/${P}-fix-test-requirements.patch" )
-
-distutils_enable_tests pytest
-
-src_install() {
- distutils-r1_src_install
-
- use examples && dodoc examples/patterns/*.py
-}