summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-debug-toolbar/django-debug-toolbar-3.2.1.ebuild')
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-3.2.1.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-3.2.1.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-3.2.1.ebuild
deleted file mode 100644
index 06f03d13eb93..000000000000
--- a/dev-python/django-debug-toolbar/django-debug-toolbar-3.2.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="A configurable set of panels that display debug information"
-HOMEPAGE="
- https://pypi.org/project/django-debug-toolbar/
- https://github.com/jazzband/django-debug-toolbar/"
-SRC_URI="https://github.com/jazzband/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/django-1.11[${PYTHON_USEDEP}]
- >=dev-python/sqlparse-0.2.0[${PYTHON_USEDEP}]
-"
-DEPEND="
- test? (
- $(python_gen_impl_dep sqlite)
- ${RDEPEND}
- )
-"
-
-distutils_enable_sphinx docs
-
-python_test() {
- emake TEST_ARGS='-v 2 tests' test
-}
-
-python_install_all() {
- if use examples; then
- docinto examples
- dodoc -r example/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}